Frequently triggers "TypeError: this._searchSuggestionController is null"

VERIFIED FIXED in Firefox 42

Status

()

Firefox
Location Bar
P2
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: xidorn, Assigned: mak)

Tracking

Trunk
Firefox 42
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox42 verified)

Details

(Whiteboard: [unifiedautocomplete][suggestions][fxsearch])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
The complete error info is:
A coding exception was thrown in a Promise resolution callback.
See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise

Full message: TypeError: this._searchSuggestionController is null
Full stack: _matchSearchSuggestions/promise<@file:///c:/mozilla-source/central/obj-firefox/dist/bin/components/UnifiedComplete.js:937:1
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:934:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:813:7
Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:744:11
this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:776:7
this.PromiseWalker.completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:711:7
this.SearchSuggestionController.prototype._fetchRemote/<@resource://gre/modules/SearchSuggestionController.jsm:250:54
this.SearchSuggestionController.prototype.stop@resource://gre/modules/SearchSuggestionController.jsm:172:7
stop@resource://gre/modules/PlacesSearchAutocompleteProvider.jsm:181:5
stop@file:///c:/mozilla-source/central/obj-firefox/dist/bin/components/UnifiedComplete.js:775:7
UnifiedComplete.prototype.stopSearch@file:///c:/mozilla-source/central/obj-firefox/dist/bin/components/UnifiedComplete.js:1776:7
handleEnter@chrome://browser/content/urlbarBindings.xml:890:1
handleKeyPress@chrome://global/content/bindings/autocomplete.xml:479:24
onKeyPress@chrome://browser/content/urlbarBindings.xml:199:18
onxblkeypress@chrome://global/content/bindings/autocomplete.xml:582:8


This error frequently appears in browser console as well as the command line output.
(Assignee)

Updated

2 years ago
Blocks: 995091
Flags: firefox-backlog?
Priority: -- → P2
Whiteboard: [unifiedautocomplete][suggestions][fxsearch]
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1189017
(Assignee)

Updated

2 years ago
Flags: firefox-backlog? → firefox-backlog+
(Assignee)

Updated

2 years ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
(Assignee)

Comment 2

2 years ago
Created attachment 8642436 [details] [diff] [review]
patch v1
Attachment #8642436 - Flags: review?(ttaubert)
Attachment #8642436 - Flags: review?(ttaubert) → review+

Comment 3

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/c2b099fa12ee
https://hg.mozilla.org/mozilla-central/rev/c2b099fa12ee
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox42: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Flags: qe-verify+
QA Contact: andrei.vaida
Reproduced the bug on Nightly 42.0a1 (2015-08-03).

I'm no longer seeing these errors as of Nightly 42.0a1 (2015-08-05). Tested with Windows 10 x64 (10240), Ubuntu 14.04 (x86) and Mac OS X 10.10.4.
Status: RESOLVED → VERIFIED
status-firefox42: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.