Closed Bug 1189443 Opened 6 years ago Closed 6 years ago

Elements flash/disappear on specific webpage

Categories

(Core :: Panning and Zooming, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox43 --- fixed

People

(Reporter: dqeswn, Assigned: kats)

References

()

Details

Attachments

(2 files)

On this page the lower section of the page constantly blinks/disappears when I scroll with APZ turned on when I'm using my main profile.

It looks like I need to have e10s enabled too.
Blocks: apz-desktop, e10s
(In reply to avada from comment #0)
> It looks like I need to have e10s enabled too.

Yeah, APZ is disabled if e10s is disabled. Also, what platform are you seeing this on?
No longer blocks: e10s
(And also what version/build of FF?)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #1)
> (In reply to avada from comment #0)
> > It looks like I need to have e10s enabled too.
> 
> Yeah, APZ is disabled if e10s is disabled. Also, what platform are you
> seeing this on?

Info added.



(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)
> (And also what version/build of FF?)

Trunk was already set. I tried yesterday and today.
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64
#1 Regression (hang when scroll)
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=cbe91037c39d&tochange=14c8c3fd403c

Triggered by: Bug 1156401


#2 Regression (Fixed the hang, but flicker when scroll)
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1a33c4ca043c&tochange=cc76f739f1cc

Triggered by: cc76f739f1cc	Kartikaya Gupta — Bug 1161040 - Don't set a scrollparent on the root content document in the child process that points to itself. r=tn
Blocks: 1161040
Attached image bugpic
Im having the same issue of elements on pages disappearing while I scroll.  
I tried with and without HWA.  
Seems like its appears to happen with HWA on.  

Webpage - https://www.reddit.com/r/microsoft/comments/3fcf0l/windows_10_is_now_installed_on_67_million_pcs_as/
Firefox Nighlty - 42.0a1 (2015-08-01); Windows 7 Ultimate.


Graphics Info:-
Adapter Description	Intel(R) HD Graphics Family
Adapter Description (GPU #2)	NVIDIA GeForce GT 525M
Adapter Drivers	igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
Adapter Drivers (GPU #2)	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM	Unknown
Adapter RAM (GPU #2)	1024
Asynchronous Pan/Zoom	wheel input enabled
ClearType Parameters	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
Device ID	0x0116
Device ID (GPU #2)	0x0df5
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.17292)
Driver Date	4-10-2011
Driver Date (GPU #2)	4-8-2015
Driver Version	8.15.10.2361
Driver Version (GPU #2)	9.18.13.5012
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	04ca1028
Subsys ID (GPU #2)	04ca1028
Supports Hardware H264 Decoding	true
Vendor ID	0x8086
Vendor ID (GPU #2)	0x10de
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_4_1 ps_4_1)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0



Also it appears that it affects MacOS users too:
https://www.reddit.com/r/firefox/comments/3f9i9b/some_strange_graphic_problems_it_is_firefox/
I didn't see anything unusual on that reddit page and where it links to.

Did you try the url for this bug? If you don't experience it there yours is not the same bug.
I can repro the original report (comment 0) and based on paint-flashing I think this is again caused by the checkerboard-background-painting code in the compositor. I'll investigate more.
Assignee: nobody → bugmail.mozilla
Blocks: all-aboard-apz
No longer blocks: apz-desktop
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch PatchSplinter Review
Truncating the displayport margins during the float->int conversion was causing the displayport to be smaller than expected. If you scrolled near the edge of the page on pages of certain dimensions it would result in the APZ code checkerboarding and drawing a background. This fixes it. Note that I left the "budget" amount as an int; we probably still want to err on the side of a smaller budget. In most cases the displayport margins aren't hitting the budget anyway so it doesn't make a difference.
Attachment #8645002 - Flags: review?(dvander)
Attachment #8645002 - Flags: review?(dvander) → review+
https://hg.mozilla.org/mozilla-central/rev/9f9f2d1ddb8c
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Depends on: 1263192
You need to log in before you can comment on or make changes to this bug.