Closed Bug 1189532 Opened 5 years ago Closed 5 years ago

Add Bambara (bm) and Malagasy (mg) locales to master and 2.2 builds

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-v2.2r fixed, b2g-master fixed)

RESOLVED FIXED
FxOS-S7 (18Sep)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- fixed
b2g-v2.2r --- fixed
b2g-master --- fixed

People

(Reporter: tchevalier, Assigned: tchevalier)

References

Details

Attachments

(2 files)

As per possible partner interest (see https://mana.mozilla.org/wiki/display/PM/Firefox+OS+Wave+Launch+Cross+Functional+View ), we need those two locales on 2.2 and onwards.

Getting the patch ready until we finish 2.2/2.5 l10n branching ( https://l10n.etherpad.mozilla.org/gaia-2-2-master-branch-merge )
Duplicate of this bug: 1183933
Assignee: nobody → theo
Comment on attachment 8641344 [details] [review]
[gaia] TheoChevalier:bug1189532-add-bm-mg > mozilla-b2g:master

Hey stas, now that 2.5 branch out is close, could you have a look when you'll be back please? :)
Attachment #8641344 - Flags: review?(stas)
Depends on: 1199895
Comment on attachment 8641344 [details] [review]
[gaia] TheoChevalier:bug1189532-add-bm-mg > mozilla-b2g:master

Great, thanks for updating the layout definitions of other languages, too!
Attachment #8641344 - Flags: review?(stas) → review+
Dwayne just pushed initial content to the repos, we're good to merge to master and ask for uplift on 2.2
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/fdaa25b9347e2b29ddf6c026f80be0f4554406b9
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S7 (18Sep)
Comment on attachment 8641344 [details] [review]
[gaia] TheoChevalier:bug1189532-add-bm-mg > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: Users won't be able to use the device in their language, partner request won't be satisfied
[Testing completed]: Aries latest master
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: N/A
Attachment #8641344 - Flags: approval-gaia-v2.2?(jocheng)
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → 2.2+
Attachment #8641344 - Flags: approval-gaia-v2.2?(jocheng) → approval-gaia-v2.2+
theo: would it be possible to add a pull request for 2.2r now that it has approval and i will do the merge then
Flags: needinfo?(tchevalier)
2.2 or 2.2r specifically?
Flags: needinfo?(tchevalier)
Hi Theo,
Just 2.2 will do. I think Tomcat means 2.2 instead of 2.2r. 
Tomcat will merge 2.2 to 2.2r regularly. Thanks!
Flags: needinfo?(tchevalier)
Done, let me know if anything else is needed :)
Flags: needinfo?(tchevalier)
merged over 2.2 to 2.2r
You need to log in before you can comment on or make changes to this bug.