If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Potential unsafe use of MediaSourceDemuxer::NotifyTimeRangesChanged

RESOLVED FIXED in Firefox 42, Firefox OS master

Status

()

Core
Audio/Video: Playback
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jya, Assigned: jya)

Tracking

Trunk
mozilla42
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 unaffected, firefox41 unaffected, firefox42 fixed, firefox-esr38 unaffected, b2g-v2.0 unaffected, b2g-v2.0M unaffected, b2g-v2.1 unaffected, b2g-v2.1S unaffected, b2g-v2.2 unaffected, b2g-v2.2r unaffected, b2g-master fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
This causes the backout of bug 1184867 even though it has nothing to do with this patch.

(it just occurred without that change in http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/fx-team-win64/1438288664/fx-team_win8_64_test-web-platform-tests-3-bm119-tests1-windows-build203.txt.gz)

bug 1189138 have slightly changed the timing in which the mediasourcedemuxer is notified of data ; causing the issue to appear.
(Assignee)

Comment 1

2 years ago
Created attachment 8641466 [details] [diff] [review]
0001-Bug-1189588-MSE-Remove-MediaSourceDemuxer-NotifyTime.patch
Attachment #8641466 - Flags: review?(cpearce)
(Assignee)

Updated

2 years ago
Assignee: nobody → jyavenard
Attachment #8641466 - Flags: review?(cpearce) → review+

Comment 2

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/8e247a5f9f97
Marking SS based on comment 0 indicating the issue existed prior to the bugs mentioned there.
Group: core-security
https://hg.mozilla.org/mozilla-central/rev/8e247a5f9f97
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox42: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1189723
How severe is this? Does it affect older branches? Do we need to worry about backporting?
Flags: needinfo?(jyavenard)
(Assignee)

Comment 7

2 years ago
the new mediasource is only active in 42.

it can be turned on in 41 by switching a pref but I wouldn't worry about it.
Flags: needinfo?(jyavenard)
status-firefox41: --- → unaffected
status-b2g-v2.0: --- → unaffected
status-b2g-v2.0M: --- → unaffected
status-b2g-v2.1: --- → unaffected
status-b2g-v2.1S: --- → unaffected
status-b2g-v2.2: --- → unaffected
status-b2g-v2.2r: --- → unaffected
status-b2g-master: --- → fixed
status-firefox40: --- → unaffected
status-firefox-esr38: --- → unaffected

Updated

2 years ago
Group: core-security → core-security-release
Group: core-security-release
You need to log in before you can comment on or make changes to this bug.