New Message, select a list and display addresses expanded instead of list name

VERIFIED FIXED in Future

Status

enhancement
P3
normal
VERIFIED FIXED
20 years ago
15 years ago

People

(Reporter: CodeMachine, Assigned: racham)

Tracking

({helpwanted})

Firefox Tracking Flags

(Not tracked)

Details

This is a request from someone else who has a list of classmates' emails.  He
needs a facility to insert a list of addresses in an email to send the current
list to new people he's found.  There doesn't seem to be any easy way to do this
in 4.x, since lists only expand in To/CC/BCC fields, and he doesn't want to send
to most people on the list.

Hence it would be nice to have an Insert Address(es) action where you can select
a list of cards/lists from the address book, have all lists expanded, the
addresses sorted, and then have them appear in the body separated by commas or
newlines (at the user's choice).

Is there an easier way to do this right now?
Status: NEW → ASSIGNED
Target Milestone: M15
I will see what I can do here.  It looks like this should be possible to

accomplish with drag and drop.
QA Contact: lchiang → esther
Sounds feasible, if not a little obscure.  Maybe augment it with a "Copy E-Mail
Addresses" menu option to make it more obvious?
Bouncing to later milestone
Target Milestone: M15 → M20
Mass move mailnews bugs to Putterman.  Ouch.
Assignee: hangas → putterman
Status: ASSIGNED → NEW
Move to future target milestone for review in a later release.  Add helpwanted 
keyword.
Keywords: helpwanted
Target Milestone: M20 → Future
reassigning to chuang.
Assignee: putterman → chuang
QA-assign-to fenella.
QA Contact: pmock → fenella
*** Bug 91743 has been marked as a duplicate of this bug. ***
reassigning to racham
Assignee: chuang → racham
QA Contact: fenella → nbaca
Changing summary from "Ability to add addresses to body." to "New Message,
select a list and display addresses expanded instead of list name", allowing the
user to delete unwanted recipients.
Summary: Ability to add addresses to body. → New Message, select a list and display addresses expanded instead of list name
I think bhuvan fixed this during 0.9.8.
To have addresses expanded in the compose window, click on the desired list on
the left pane i.e., directory pane and then either click on 'Compose' button on
toolbar of addressbook window or select File|New|Message. Selecting multiple
addresses in the results pane i.e., pane where addresses are listed and then
triggering the action also works. Marking this fixed.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Trunk build 2002-01-25-03: WinMe
Trunk build 2002-01-28-08: Linux RH 7.1
Trunk build 2002-01-28-08: Mac 10.1
Verified Fixed.

a. Select list from directory pane, Compose button (or File|New Message), list 
of recipients expanded.
Note: Select list from results pane, Compose button (or File|New Message), list 
name only. After sending/receiving the message, list of recipients is expanded.

b. Select multiple cards from results pane, Compose button, list of recipients 
expanded.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.