Closed Bug 1189817 Opened 5 years ago Closed 4 years ago

large talos e10s regressions on windows July 24th on mozilla-central

Categories

(Testing :: Talos, defect)

defect
Not set
normal

Tracking

(e10s-)

RESOLVED WORKSFORME
Tracking Status
e10s - ---

People

(Reporter: jmaher, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: perf, regression, Whiteboard: [talos_regression][e10s])

46 commits in a merge to m-c:
https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=9bca608ab65a

yields a lot of windows regressions on e10s only:
http://alertmanager.allizom.org:8080/alerts.html?rev=9bca608ab65a&showAll=1&testIndex=0&platIndex=0

In summary these regressions are:
tresize - 15.8-39.7%
tpaint - 4.8% (win7 only)
tsvg_opacity - 2.9-3.2% (win7/win8)
tart - 6.8 - 7.1% 
tsvg - 4.8-6.5% (win7/win8)
tscroll - 40-51% (win7/win8)
** winxp has a 15% win
cart - 3.8% (win7)
** winxp has a 3.8% win
tp5o_scroll - 136-250%
damp - 4.6% - 6.8%
not tracking for e10s because this is APZ related
tracking-e10s: --- → -
Bug 1191539 caused several large improvements to tscroll-asap and tp5 on windows which were the some of the worse offenders here.

tresize should be improved by bug 1186662 but it will only improve if we're doing a real scroll (we get the windows sizemove message) so we might still have a large regression during synthetic resize.
Duplicate of this bug: 1179735
We have made a bunch of improvements over time in various bugs, and there are a couple other still open for more specific things. The remaining regressions are just going to be accepted. There's no value in leaving this bug open anymore, I think.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.