Disabled Document/More in site navigation bar (links bar) use bookmark icon in Classic

RESOLVED FIXED

Status

SeaMonkey
UI Design
RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: Greg Valure, Assigned: Stuart Ballard)

Tracking

({testcase})

Trunk
x86
Windows 98
testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

91 bytes, text/html
Details
526 bytes, patch
Stuart Ballard
: review+
Joe Hewitt (gone)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
As seen in the testcase, when the Document and More folders are disabled, they
use a disabled bookmark icon instead of a disabled folder icon.

2002-01-06-08 Win98
(Reporter)

Comment 1

16 years ago
Created attachment 64149 [details]
testcase
(Reporter)

Updated

16 years ago
Blocks: 103053
(Assignee)

Comment 2

16 years ago
Which skin(s) do you see this in? (please test both modern and classic and let
me know). This sounds a lot like another bug whose number I forget that was
modern-only.
(Reporter)

Comment 3

16 years ago
This appears to be Classic only.
Summary: Disabled Document/More in site navigation bar (links bar) use bookmark icon → Disabled Document/More in site navigation bar (links bar) use bookmark icon in Classic
QA Contact: sairuh → claudius
Stuart, remember how I was confused why that other bug was modern-only because
both themes used !important?  :)  I think you just need to add !important in
classic as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

16 years ago
Probably, but it's in a different place :) That bug was the "next", "previous"
etc items, this is "Document" and "More". I'll look into this - as you say, it
probably does just need an !important somewhere.

Comment 6

16 years ago
reassigning.
Assignee: blaker → sballard
Keywords: testcase
(Reporter)

Comment 7

16 years ago
Searching through the source, I found the only references to
bookmark-item-disabled.gif are in bookmarksToolbar.css.  It only appears on
lines 77 and 117, neither of which have an !important.

http://lxr.mozilla.org/mozilla/source/themes/classic/communicator/bookmarks/bookmarksToolbar.css#77
http://lxr.mozilla.org/mozilla/source/themes/classic/communicator/bookmarks/bookmarksToolbar.css#117

Of the two equivalent references in the Modern theme, only the first has an
!important.

http://lxr.mozilla.org/mozilla/source/themes/modern/communicator/bookmarks/bookmarksToolbar.css#79
http://lxr.mozilla.org/mozilla/source/themes/modern/communicator/bookmarks/bookmarksToolbar.css#119

So can someone now finish off this bug?  I'd like to get this in for 1.0, since
it's an easily visible flaw.
(Assignee)

Comment 8

16 years ago
Greg, if you're able to look at the source in lxr to identify the style rules
that are the problem, you should have no difficulty creating a patch yourself.
Download Patch Maker and it's requirements from
http://www.mozilla.org/hacking/patch-maker and follow the instructions there.
You should be easily able to find the skin/classic/navigator/linkToolbar.css
file and add !important to the appropriate style rules pretty easily, and you
can test your fix immediately by just re-running mozilla.

If you attach a patch to the bug I'll certainly give it r= and help with chasing
up sr= and a=.
(Reporter)

Comment 9

16 years ago
Created attachment 74125 [details] [diff] [review]
Patch

That one !important is what did the trick.
(Assignee)

Comment 10

16 years ago
The patch looks good to me; I'll give an official r= either later today or
tomorrow, when I've had time to test it.
(Assignee)

Comment 11

16 years ago
oh, and I should have also said - thanks for doing this! :)
(Assignee)

Comment 12

16 years ago
Comment on attachment 74125 [details] [diff] [review]
Patch

r=sballard@netreach.net

I'm really sorry for the delay - I thought I would be able to get to this
sooner but things have been incredibly hectic. I shouldn't really be doing it
now, either, since I'm on company time, but what the heck - it didn't take
long. Just that every night last week, and this whole weekend, my computer
never even got turned on, there was so much else to do.

Anyway, I've sent an sr request so hopefully we can get that soon too.
Attachment #74125 - Flags: review+
(Reporter)

Comment 13

16 years ago
Don't worry about it then.  I'll handle getting the a= and checkin.

Comment 14

16 years ago
Comment on attachment 74125 [details] [diff] [review]
Patch

sr=hewitt
Attachment #74125 - Flags: superreview+

Updated

16 years ago
Attachment #74125 - Flags: approval+

Comment 15

16 years ago
Comment on attachment 74125 [details] [diff] [review]
Patch

a=asa (on behalf of drivers) for checkin to the 1.0 trunk

Comment 16

16 years ago
has this been checked in? time is running out.
Fixed.

Checking in themes/classic/communicator/bookmarks/bookmarksToolbar.css;
/cvsroot/mozilla/themes/classic/communicator/bookmarks/bookmarksToolbar.css,v 
<--  bookmarksToolbar.css
new revision: 1.19; previous revision: 1.18
done

Gerv
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.