Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Need better type checking of arguments for open extension API

RESOLVED DUPLICATE of bug 1208257

Status

()

Toolkit
WebExtensions: Untriaged
P2
normal
RESOLVED DUPLICATE of bug 1208257
2 years ago
2 years ago

People

(Reporter: billm, Unassigned)

Tracking

(Blocks: 1 bug)

34 Branch
Points:
---
Dependency tree / graph
Bug Flags:
blocking-webextensions +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Right now arguments aren't checked at all. If the wrong type is passed in, weird things will probably happen.

We should use the .json files that Google has for the API interfaces to check argument types. This would also simplify the handling of optional arguments.
(Reporter)

Comment 1

2 years ago
Link to how Google does this.
Flags: needinfo?(wmccloskey)
Priority: -- → P2
(Reporter)

Comment 2

2 years ago
Here's a sample JSON file:
https://code.google.com/p/chromium/codesearch#chromium/src/chrome/common/extensions/api/windows.json&sq=package:chromium&type=cs&l=121
Flags: needinfo?(wmccloskey)
(Reporter)

Updated

2 years ago
Component: Extension Compatibility → WebExtensions
Product: Firefox → Toolkit

Updated

2 years ago
Blocks: 1208257

Updated

2 years ago
No longer blocks: 1208257
Depends on: 1208257

Updated

2 years ago
Blocks: 1214433

Updated

2 years ago
Flags: blocking-webextensions+

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1208257
You need to log in before you can comment on or make changes to this bug.