Bug 1214433 (webext)

[Tracking] Web Extensions Development

RESOLVED FIXED

Status

defect
P4
normal
RESOLVED FIXED
4 years ago
5 months ago

People

(Reporter: andy+bugzilla, Unassigned)

Tracking

(Depends on 14 bugs, {meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: triaged, meta)

User Story

For the bugs that are targeted for 57 - use this query https://mzl.la/2oe1O9Z

This bug is holding meta bugs related to webextensions.  They aren't all ones that are committed to - but they give a way to see the meta bugs overview when talking about higher level capabilities.
Reporter

Description

4 years ago
Web Extensions are kind of there are already, but this tracks all the bugs we want to complete to get to a first release of Web Extensions.
Reporter

Updated

4 years ago
Reporter

Updated

4 years ago
No longer depends on: webextensions-chrome-gaps
Reporter

Updated

4 years ago
Depends on: 1156826
Reporter

Updated

4 years ago
Depends on: 1185459
Reporter

Updated

4 years ago
Depends on: 1185460
Reporter

Updated

4 years ago
Depends on: webext-android
Depends on: 1215197
Reporter

Updated

4 years ago
Depends on: 1190663
Reporter

Updated

4 years ago
Depends on: 1190677
Reporter

Updated

4 years ago
Depends on: webext-oop
Reporter

Updated

4 years ago
Depends on: 1190685
Reporter

Updated

4 years ago
Depends on: 1190688
Reporter

Updated

4 years ago
Depends on: 1190689
Reporter

Updated

4 years ago
Depends on: 1190690
Reporter

Updated

4 years ago
Depends on: 1192432
Reporter

Updated

4 years ago
Depends on: 1192433
Reporter

Updated

4 years ago
Depends on: 1192435
Reporter

Updated

4 years ago
Depends on: 1192437
Reporter

Updated

4 years ago
Depends on: 1192439
Reporter

Updated

4 years ago
Depends on: 1193837
Reporter

Updated

4 years ago
Depends on: 1197346
Reporter

Updated

4 years ago
Depends on: 1197420
Reporter

Updated

4 years ago
Depends on: 1197422
Reporter

Updated

4 years ago
Depends on: 1198405
Reporter

Updated

4 years ago
Depends on: 1199050
Reporter

Updated

4 years ago
Depends on: 1199052
Reporter

Updated

4 years ago
Depends on: 1199056
Reporter

Updated

4 years ago
Depends on: 1199253
Reporter

Updated

4 years ago
Depends on: 1200146
Reporter

Updated

4 years ago
Blocks: 1200674
Reporter

Updated

4 years ago
No longer blocks: 1200674
Depends on: 1200674
Reporter

Updated

4 years ago
Depends on: 1202734
Reporter

Updated

4 years ago
Depends on: 1203233
Reporter

Updated

4 years ago
Depends on: 1203330
Reporter

Updated

4 years ago
Depends on: 1203738
Reporter

Updated

4 years ago
Depends on: 1205886
Reporter

Updated

4 years ago
Depends on: 1207394
Reporter

Updated

4 years ago
Depends on: 1207597
Depends on: 1215375
Reporter

Updated

4 years ago
Depends on: 1213426
Reporter

Updated

4 years ago
Depends on: 1213433
Reporter

Updated

4 years ago
Depends on: 1213450
Reporter

Updated

4 years ago
Depends on: webext-tabs
Reporter

Updated

4 years ago
Depends on: webext-webnav
Reporter

Updated

4 years ago
Depends on: webRequest-full
Reporter

Updated

4 years ago
Depends on: webext-windows
Reporter

Updated

4 years ago
Depends on: 1213895
Reporter

Updated

4 years ago
Depends on: 1213975
Reporter

Updated

4 years ago
Depends on: 1213993
Reporter

Updated

4 years ago
Depends on: 1214007
Reporter

Updated

4 years ago
Depends on: 1214040
Reporter

Updated

4 years ago
Depends on: 1214658
Reporter

Updated

4 years ago
Depends on: 1214790
Reporter

Updated

4 years ago
Depends on: 1214952
Reporter

Updated

4 years ago
Depends on: 1214955
Reporter

Updated

4 years ago
Depends on: 1215130
Depends on: 1215893
Reporter

Updated

4 years ago
Depends on: 1213632
Reporter

Updated

4 years ago
Depends on: 1217879
Reporter

Updated

4 years ago
Flags: blocking-webextensions-
Depends on: 1218175
Depends on: 719905
OS: Unspecified → All
Hardware: Unspecified → All
Depends on: 1230447
Depends on: 1235005
Depends on: 1238585
Reporter

Updated

3 years ago
Depends on: 1239109
No longer depends on: 1215775
Depends on: 1239822
Depends on: 1244474
Reporter

Updated

3 years ago
Whiteboard: triaged
Depends on: 1246748
Depends on: 1246749
Depends on: 1246754
Reporter

Updated

3 years ago
No longer depends on: 1199718

Comment 1

3 years ago
Is this the death of FireFox? Let me rephrase it: will this make addons like "Classic Theme Restorer" impossible after XUL/XPCOM support is discontinued?

Comment 2

3 years ago
(In reply to Sergey Rozhenko from comment #1)
> Is this the death of FireFox? Let me rephrase it: will this make addons like
> "Classic Theme Restorer" impossible after XUL/XPCOM support is discontinued?

Last I heard, the plan was to replace traditional XUL/XPCOM with a mechanism where a WebExtensions addon could depend on a more manually-reviewed "native.js" module which adds new APIs to what the WebExtensions environment can see.

(The idea being that, over time, these "native.js" modules would get refined and then merged in as new official APIs.)

Comment 3

3 years ago
(In reply to Stephan Sokolow from comment #2)

Ah, good then. I was worried we could lose the full customizability of FF, which is its core feature.
Depends on: 1267027
Reporter

Comment 4

3 years ago
This was tracking stuff we wanted to do for 48. That version of Firefox has been and going. Sadly we didn't get everything on this list (there was a lot), but we got a lot of stuff done. We haven't really been using this tracking bug anymore, rather using the blocking-webextensions flag.

For that reason, I'm going to close this bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 5

2 years ago
(In reply to Sergey Rozhenko from comment #3)
> (In reply to Stephan Sokolow from comment #2)
> 
> Ah, good then. I was worried we could lose the full customizability of FF,
> which is its core feature.

Indeed, that will happen, because the relevant bug was WONTFIXed on the grounds that native.js is incompatible with Mozilla's vision for Firefox.

Comment 6

2 years ago
(In reply to Mitth'raw'nuruodo from comment #5)
> (In reply to Sergey Rozhenko from comment #3)
> > (In reply to Stephan Sokolow from comment #2)
> > 
> > Ah, good then. I was worried we could lose the full customizability of FF,
> > which is its core feature.
> 
> Indeed, that will happen, because the relevant bug was WONTFIXed on the
> grounds that native.js is incompatible with Mozilla's vision for Firefox.

*nod* Given that Firefox has no --enable-easy-off-store-extension-install equivalent to allow a secondary ecosystem to develop, as has occurred for YouTube downloaders on Chrome, that makes a XUL-less AMO even less free than Chrome's ecosystem. (Not even counting Firefox not yet having support for APIs like chrome.downloads.onDeterminingFilename)

As soon as that change was announced, I started making plans to ride the trains down from Aurora through ESR and then switch to something like Seamonkey or Pale Moon. (Or even Chrome, given that Chrome at least has an actual menu behind the hamburger button rather than the "toolbar buttons in a panel" touchscreen/toy interface I'll be forced onto if Classic Theme Restorer dies out.)

At the moment, given that I've finally lost faith in Mozilla and don't have high hopes for anyone else developing an acceptable ecosystem, I'm working to find/write browser-agnostic solutions for as much as possible of what I currently rely on extensions for (eg. adding a new root into the CA store and setting up an HTTPS-capable proxy to reinvent conveniences like InlineDisposition as well as my privacy and security extensions) in a way that'll work with any browser.

...and, of course, I've prioritized my efforts to write an external bookmark manager with an interface capable of scaling to the volume and complexity I need. (I already use an external password manager, so that's not an issue.)

Comment 7

2 years ago
...though I suppose another potential option would be if something like Qt's QWebEngine gained built-in support for loading WebExtensions.

Then this push toward the lowest common denominator would mean it'd be feasible for me to maintain my own homegrown browser frontend on top of Blink+WebExtensions. (Actually, to be honest, that'd be even more appealing than if Firefox hadn't started retiring XUL.)

Updated

2 years ago
Blocks: 1329713

Updated

2 years ago
Alias: webext1.0 → webext
Blocks: 1335456
No longer blocks: 1329713
Keywords: meta
Priority: -- → P4
Summary: [tracking] First release of Web Extensions → [Tracking] Web Extensions Development
Whiteboard: triaged → triaged, meta

Updated

2 years ago
Depends on: 1303905

Updated

2 years ago
Depends on: 1333837

Updated

2 years ago
Depends on: webext-more-ui

Updated

2 years ago
Depends on: webext-popups

Updated

2 years ago
User Story: (updated)

Comment 8

2 years ago
This bug was closed 10 months ago. Is it going to reopen for all these bugs that it depends on to be resolved?

Updated

2 years ago
Depends on: 1385202
Duplicate of this bug: 1329713

Updated

2 years ago
No longer depends on: 1385202

Updated

2 years ago
Depends on: 1416207

Updated

a year ago
Depends on: Session_managers

Updated

a year ago
Depends on: webext-tb

Updated

11 months ago
Product: Toolkit → WebExtensions

Updated

9 months ago
Depends on: 1483598

Updated

9 months ago
Depends on: webext-geckoview
No longer depends on: webext-geckoview

Updated

7 months ago
Depends on: 1226546

Updated

7 months ago
Depends on: 1232178
No longer depends on: 1226546, 1232178

Updated

5 months ago
Depends on: 1305109
No longer depends on: 1305109
Please stop adding dependencies to this bug.
You need to log in before you can comment on or make changes to this bug.