Closed Bug 1190988 Opened 5 years ago Closed 5 years ago

Hit testing appears to return incorrect positions when --enable-android-apz is specified.

Categories

(Core :: Panning and Zooming, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla42
Tracking Status
firefox42 --- fixed

People

(Reporter: rbarker, Assigned: rbarker)

References

Details

Attachments

(1 file, 1 obsolete file)

Using the test page: http://bluemarvin.github.io/html/grid.html which will draw an 'X' where ever it is tapped, it appears that the hit testing is returning incorrect values when --enable-android-apz is specified because the 'X' is not drawn in the location of the tap. It seems that zoom may be a factor. When the page is zoomed all the way out. The tapping seems to work for the upper left quarter of the screen but not for the rest of the screen.
Attachment #8644461 - Flags: review?(bugmail.mozilla)
Assignee: nobody → rbarker
Comment on attachment 8644461 [details] [diff] [review]
0001-Bug-1190988-Hit-testing-appears-to-return-incorrect-positions-when-enable-android-apz-is-specified-15080610-4271620.patch

Review of attachment 8644461 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/chrome/content/browser.js
@@ +441,5 @@
>      dump("zerdatime " + Date.now() + " - browser chrome startup finished.");
>  
>      this.deck = document.getElementById("browsers");
>  
> +    // This check and BrowserEventHandler should be removed once we have switched over to NAPZ

s/NAPZ/the C++ APZ code/
Attachment #8644461 - Flags: review?(bugmail.mozilla) → review+
Keywords: checkin-needed
Duplicate of this bug: 1190979
https://hg.mozilla.org/mozilla-central/rev/90d854c1fb68
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
You need to log in before you can comment on or make changes to this bug.