Upgrade font support to Graphite 1.3.0 just released

RESOLVED FIXED in Firefox 43

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: martin_hosken, Assigned: jfkthame)

Tracking

42 Branch
mozilla43
Points:
---

Firefox Tracking Flags

(firefox43 fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Graphite2 1.3.0 has just been released. No API changes and the integration has already been tested in bug #1184473.

Release source can be downloaded from: 

http://projects.palaso.org/attachments/download/427/graphite2-1.3.0.tgz
http://sourceforge.net/projects/silgraphite/files/graphite2/graphite2-1.3.0.tgz/download
(Assignee)

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

3 years ago
Created attachment 8643635 [details] [diff] [review]
Update graphite2 library to release 1.3.0
Attachment #8643635 - Flags: review?(jdaggett)
(Assignee)

Updated

3 years ago
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
(Assignee)

Comment 3

3 years ago
Martin, I notice the BSD license block in Decompressor.{h,cpp} is different from the GPL/MPL headers in most files, and claims "Copyright (c) 2012, Siyuan Fu ..." in addition to SIL. Could you confirm where this comes from, so we can make sure to attribute it appropriately? From a quick Google search, I'm guessing it may be derived from https://code.google.com/p/data-shrinker/, though it looks like you've massaged the code considerably; or is there a different (newer?) upstream source?
Flags: needinfo?(martin_hosken)
(Reporter)

Comment 4

3 years ago
I can confirm that the original code came from https://code.google.com/p/data-shrinker but that it has been heavily modified by us.
Flags: needinfo?(martin_hosken)
(Assignee)

Comment 5

3 years ago
Created attachment 8643757 [details] [diff] [review]
pt 2 - Add data-shrinker license to about:license

I assume we should add this, to ensure we properly acknowledge the copyright on these two files.
Attachment #8643757 - Flags: review?(gerv)
Comment on attachment 8643757 [details] [diff] [review]
pt 2 - Add data-shrinker license to about:license

Review of attachment 8643757 [details] [diff] [review]:
-----------------------------------------------------------------

r=gerv.

Gerv
Attachment #8643757 - Flags: review?(gerv) → review+

Updated

3 years ago
Attachment #8643635 - Flags: review?(jdaggett) → review+
(Assignee)

Comment 7

3 years ago
url:        https://hg.mozilla.org/integration/mozilla-inbound/rev/fc9a4891714ba18330acfc4bdd7ea822f05a0e8c
changeset:  fc9a4891714ba18330acfc4bdd7ea822f05a0e8c
user:       Jonathan Kew <jkew@mozilla.com>
date:       Mon Aug 10 09:38:46 2015 +0100
description:
Bug 1191167 - Update graphite2 library to release 1.3.0. r=jdaggett

url:        https://hg.mozilla.org/integration/mozilla-inbound/rev/675cecb64f753eaa8769a71d43bf8fdac272e006
changeset:  675cecb64f753eaa8769a71d43bf8fdac272e006
user:       Jonathan Kew <jkew@mozilla.com>
date:       Mon Aug 10 09:39:15 2015 +0100
description:
Bug 1191167 pt 2 - Add data-shrinker license to about:license. r=gerv
(Assignee)

Comment 8

3 years ago
Created attachment 8645828 [details] [diff] [review]
followup, avoid unnecessary new static constructors in graphite2

It turns out the new graphite version has increased the number of static constructors in Gecko by 3. We try to avoid this, because they hurt startup time. Looking at the code, I think it's straightforward to avoid the increase here; Martin, please take a look at this patch, and apply upstream if appropriate. Thanks.
Attachment #8645828 - Flags: feedback?(martin_hosken)
https://hg.mozilla.org/mozilla-central/rev/fc9a4891714b
https://hg.mozilla.org/mozilla-central/rev/675cecb64f75
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox43: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
(Reporter)

Updated

3 years ago
Attachment #8645828 - Flags: feedback?(martin_hosken) → feedback+
You need to log in before you can comment on or make changes to this bug.