Remove requirement to specify SMTP server during installation on Windows

RESOLVED FIXED in Bugzilla 5.0

Status

()

Bugzilla
Installation & Upgrading
--
enhancement
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: gerv, Assigned: gerv)

Tracking

Bugzilla 5.0
Bug Flags:
approval +
approval5.0 +

Details

Attachments

(1 attachment)

Bugzilla/Config.pm says:

>>            print "\nBugzilla requires an SMTP server to function on",
>>                  " Windows.\nPlease enter your SMTP server's hostname: ";

The original explanation in the code from 2005 (bug 280778) is:

+# Set maildeliverymethod to SMTP and prompt for SMTP server
+# if running on Windows and set to sendmail (Mail::Mailer doesn't
+# support sendmail on Windows)

We no longer use Mail::Mailer.

I think we should rip this code out, and let the admin set up mail if they want mail, or not if they don't, in the admin interface just like on every other platform.

Gerv

Updated

3 years ago
Assignee: administration → installation
Severity: normal → enhancement
Component: Administration → Installation & Upgrading

Comment 1

3 years ago
> [...]just like on every other platform.

Agreed and that's the important thing, I don't see as well why Windows should be the only platform requiring mail functionality.
Created attachment 8643774 [details] [diff] [review]
Patch v.1

Also fixes what seems like a bug in the checking function which means that the check for the path never runs.

Gerv
Assignee: installation → gerv
Status: NEW → ASSIGNED
Attachment #8643774 - Flags: review?(LpSolit)

Comment 3

3 years ago
Comment on attachment 8643774 [details] [diff] [review]
Patch v.1

r=LpSolit

For the record, sendmail support was brought back on Windows since Bugzilla 2.20 already, see bug 302418. So this code was pretty much obsolete for a long time. :)
Attachment #8643774 - Flags: review?(LpSolit) → review+

Updated

3 years ago
Flags: approval?
Target Milestone: --- → Bugzilla 6.0

Comment 4

3 years ago
To approvers: note that although it's an enhancement bug and not a bug fix, I'm still in favor of taking it for 5.0.x.

Comment 5

3 years ago
(In reply to Frédéric Buclin from comment #4)
> To approvers: note that although it's an enhancement bug and not a bug fix,
> I'm still in favor of taking it for 5.0.x.

Agreed.
Flags: approval?
Flags: approval5.0+
Flags: approval+
Target Milestone: Bugzilla 6.0 → Bugzilla 5.0
To ssh://gitolite3@git.mozilla.org/bugzilla/bugzilla.git
   553c7d9..aeb6689  master -> master

To ssh://gitolite3@git.mozilla.org/bugzilla/bugzilla.git
   29ee9d3..2d2c85f  5.0 -> 5.0

Gerv
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.