Open Bug 1191437 Opened 5 years ago Updated 4 years ago

The mute icon flashes the first time that you click on it on a window

Categories

(Core :: SVG, defect)

defect
Not set
normal

Tracking

()

REOPENED

People

(Reporter: ehsan, Unassigned)

References

Details

Markus tells me that we need to use an image stripe to work around this.
Component: Tabbed Browser → Theme
"sprite"

At least that's how we usually work around this problem. Though sometimes we use some other trick to preload the other image states, for example setting it as an offscreen background image somewhere.
(In reply to Markus Stange [:mstange] from comment #1)
> "sprite"
> 
> At least that's how we usually work around this problem. Though sometimes we
> use some other trick to preload the other image states, for example setting
> it as an offscreen background image somewhere.

I can make it a sprite, although that does remove the benefit of referencing individual elements in the SVG file.

I thought we would have to load the whole SVG file once it was referenced. Guess we only load the referenced sections?
Oh cool, I didn't know that was how it's working. I don't know what we do for SVG sections, but it seems like the flash is unnecessary then, and it would be worth filing a bug about it.
The muted icon is tab-audio.svg#tab-audio-muted as opposed to the normal icon (tab-audio.svg#tab-audio) so I guess separate sections are loaded separately...
I wonder if it's just because of the <use>? Changing the markup might fix it… I will try it and see. If not I can still make it a sprite.
Thanks!
The new icons that shorlander provided did not fix this problem, so I had to modify them myself to make a sprite out of them, and with the sprite, this will be fixed in bug 1192568.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1192568
We really shouldn't have to work around this like that. IDs are much easier to maintain than image regions.
Status: RESOLVED → REOPENED
Component: Theme → SVG
Flags: needinfo?(jwatt)
Product: Firefox → Core
Resolution: DUPLICATE → ---
Also adding Robert Longson and dholbert who seem to have worked on SVG more recently...?
We are not going to block on a platform bug fix at this point.
Blocks: 486262
No longer blocks: tab-sound-icon
Seth, do you know what's causing this?
Flags: needinfo?(seth)
(In reply to Markus Stange [:mstange] from comment #11)
> Seth, do you know what's causing this?

Yeah, I suspect I do. The symptoms above didn't make sense to me, given that we're talking about an SVG here, until I realized that this is yet another problem caused by #-moz-samplesize and #-moz-resolution, which force us to use a separate image cache entry for an image whenever the fragment identifier changes, causing us to actually have to load a second (or third, or fourth...) copy of the image.

Tell me if you've heard this one before: this will be fixed as part of downscale-during-decode. Fortunately we are getting really close now. -moz-samplesize can already be removed, and -moz-resolution should become removable during this cycle.

Clearing jwatt's needinfo since I think we have this diagnosed.
Depends on: 1120056, 1118926
Flags: needinfo?(seth)
Flags: needinfo?(jwatt)
I encounter the same bug with many SVG icons (when I hover them the 1st time in session):
0) Sound indicator (this bug)
1) "New add-on" button in urlbar (actually I think that some other urlbar buttons are affected)
2) Active "back", "forward", "reload", "bookmark" icons in context menu
CCing this bug to check if (1), (2) will be fixed as well.
Depends on: 1311246
No longer depends on: 1120056
You need to log in before you can comment on or make changes to this bug.