Add-on has no validator warnings that would prevent signing yet it is not auto approved

RESOLVED WONTFIX

Status

--
major
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: TheOne, Unassigned)

Tracking

({productwanted})

Details

(Whiteboard: [ReviewTeam][validator-phase-1])

(Reporter)

Description

3 years ago
This is the second occurrence I encouter (can't remember the first one), but https://addons.mozilla.org/en-US/editors/review/eastons-testing-agent pending prelim review is not auto-approved yet the validation report https://addons.mozilla.org/en-US/developers/addon/eastons-testing-agent/file/333940/validation does not show any warnings that would explain why.
(Reporter)

Comment 1

3 years ago
Also, that add-on suddenly appeared at the top of the unlisted prelim queue with a waiting time of 34 days, so I think the authors switched from listed to unlisted. Maybe that's why it did not get auto-approved?

Might that also be the reason for bug 1191752?
If they switched from listed to unlisted, they were not offered the automatic validation.
(Reporter)

Comment 3

3 years ago
(In reply to Mathieu Agopian [:magopian] from comment #2)
> If they switched from listed to unlisted, they were not offered the
> automatic validation.

Should we consider it? I've seen quite a few developers do that apparently because they hope their add-on will get reviewed faster...
Switching to unlisted should be very similar to submitting a new unlisted entry, so I agree there should be automatic approval when appropriate.
I thought the plan was for any existing add-ons to be disabled, and then for every future submission to be treated as a normal unlisted submission.
If there's a version pending review, I think it makes sense to assume that it was intended to be submitted as unlisted when the developer does the switch. However, I don't think it would be terrible to disable that version as long as we tell the developer to submit again.
The problem is that listed and unlisted add-ons go through a different set of validations. Also, one is expected to have an updateURL while the other is forbidden, so I wouldn't expect a pending listed version to be accepted for signing, or vice versa.
(Reporter)

Comment 8

3 years ago
(In reply to Jorge Villalobos [:jorgev] from comment #6)
> If there's a version pending review, I think it makes sense to assume that
> it was intended to be submitted as unlisted when the developer does the
> switch. However, I don't think it would be terrible to disable that version
> as long as we tell the developer to submit again.

I think that would solve some side effects as well, for example that the pending version shows up in the "Updates" queue with a waiting time of the original submission date, rather than showing up at the bottom of the "Full" or "Preliminary" unlisted queue.
Keywords: productwanted

Updated

3 years ago
Blocks: 1202063
Closing this as it was decided we won't be implementing the switch from unlisted to listed, and will remove the switch from listed to unlisted.

See bug 1200777, bug 1200779 and bug 1200785
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.