disable dromaeo_dom on all platforms

RESOLVED WONTFIX

Status

Testing
Talos
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: jmaher, Assigned: jmaher)

Tracking

(Depends on: 1 bug, {leave-open})

unspecified
mozilla42
leave-open
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 fixed, firefox42 fixed)

Details

Attachments

(3 attachments)

(Assignee)

Description

2 years ago
with persistent issues with dromaeo_dom (mostly on windows xp/7 pgo), we are going to disable this test until we can get it fixed.  I have attempted to fix it in the past unsuccessfully.
(Assignee)

Comment 1

2 years ago
Created attachment 8644523 [details] [diff] [review]
dromaeo_e10s_off.patch

I feel bad doing this whilst :bz is afk on pto, he can help us turn it back on when he gets back and can look into why this hangs the browser.
Assignee: nobody → jmaher
Status: NEW → ASSIGNED
Attachment #8644523 - Flags: review?(ryanvm)
Comment on attachment 8644523 [details] [diff] [review]
dromaeo_e10s_off.patch

Review of attachment 8644523 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me
Attachment #8644523 - Flags: review?(ryanvm) → review+
(Assignee)

Comment 3

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/f4610f8fd0be
https://hg.mozilla.org/mozilla-central/rev/f4610f8fd0be
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
https://hg.mozilla.org/releases/mozilla-aurora/rev/f7c4a6b1f9ff
status-firefox41: --- → fixed
ni for Joel so this doesn't get missed when bz is back (bz is not accepting ni :))
Flags: needinfo?(jmaher)
So wait, if the issues are on Window PGO, why did we disable on all platforms?
(Assignee)

Comment 8

2 years ago
windows pgo, windows e10s, and windows in general.  We already disabled it on osx 10.10 and windows xp.  The problem is it is not as simple as flipping a bit or doing |skipif = os == 'win'|

I am fine enabling it for linux and possibly windows 8 assuming we can get someone to look at why we get OOM so frequently on the other platforms.  Without an owner responsible for this test, I have no motivation to run it and to be honest the time the sheriffs and I put into this test to date is disproportionate to other tests.
Flags: needinfo?(jmaher)
I'd appreciate enabling this test on Linux.  I can live without Windows coverage...

We understand why the test OOMs: it generates huge DOMs on fast enough hardware, because it runs for a fixed amount of time adding stuff to the DOM.  What we don't have a good idea for is how to modify the test to avoid this problem.
(Assignee)

Updated

2 years ago
Depends on: 1199351
(Assignee)

Comment 10

2 years ago
Created attachment 8663689 [details] [diff] [review]
enable dromaeo dom for linux only- and a small bit of other cleanup

the builder diff is here:
Builders added:
+ Ubuntu HW 12.04 fx-team pgo talos g3
+ Ubuntu HW 12.04 fx-team pgo talos g3-e10s
+ Ubuntu HW 12.04 fx-team talos g3
+ Ubuntu HW 12.04 fx-team talos g3-e10s
+ Ubuntu HW 12.04 mozilla-central pgo talos g3
+ Ubuntu HW 12.04 mozilla-central pgo talos g3-e10s
+ Ubuntu HW 12.04 mozilla-central talos g3
+ Ubuntu HW 12.04 mozilla-central talos g3-e10s
+ Ubuntu HW 12.04 mozilla-inbound pgo talos g3
+ Ubuntu HW 12.04 mozilla-inbound pgo talos g3-e10s
+ Ubuntu HW 12.04 mozilla-inbound talos g3
+ Ubuntu HW 12.04 mozilla-inbound talos g3-e10s
+ Ubuntu HW 12.04 try talos g3
+ Ubuntu HW 12.04 try talos g3-e10s
+ Ubuntu HW 12.04 x64 fx-team pgo talos g3
+ Ubuntu HW 12.04 x64 fx-team pgo talos g3-e10s
+ Ubuntu HW 12.04 x64 fx-team talos g3
+ Ubuntu HW 12.04 x64 fx-team talos g3-e10s
+ Ubuntu HW 12.04 x64 mozilla-central pgo talos g3
+ Ubuntu HW 12.04 x64 mozilla-central pgo talos g3-e10s
+ Ubuntu HW 12.04 x64 mozilla-central talos g3
+ Ubuntu HW 12.04 x64 mozilla-central talos g3-e10s
+ Ubuntu HW 12.04 x64 mozilla-inbound pgo talos g3
+ Ubuntu HW 12.04 x64 mozilla-inbound pgo talos g3-e10s
+ Ubuntu HW 12.04 x64 mozilla-inbound talos g3
+ Ubuntu HW 12.04 x64 mozilla-inbound talos g3-e10s
+ Ubuntu HW 12.04 x64 try talos g3
+ Ubuntu HW 12.04 x64 try talos g3-e10s
Attachment #8663689 - Flags: review?(bugspam.Callek)
(Assignee)

Comment 11

2 years ago
reopening this until we have results working for linux
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

2 years ago
Attachment #8663689 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 12

2 years ago
Created attachment 8664787 [details] [diff] [review]
talos.json patch to add g3 (1.0)

I also added a small bit of cleanup to the patch so we can keep talos.json clean.  This will need to land on beta/aurora as well.
Attachment #8664787 - Flags: review?(armenzg)

Comment 13

2 years ago
Comment on attachment 8664787 [details] [diff] [review]
talos.json patch to add g3 (1.0)

Review of attachment 8664787 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #8664787 - Flags: review?(armenzg) → review+

Comment 14

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c005932137a2
(Assignee)

Updated

2 years ago
Keywords: leave-open

Comment 15

2 years ago
https://hg.mozilla.org/mozilla-central/rev/949d31ea7ce7
https://hg.mozilla.org/mozilla-central/rev/c005932137a2
https://hg.mozilla.org/mozilla-central/rev/949d31ea7ce7
(Assignee)

Comment 17

2 years ago
beta:
https://hg.mozilla.org/releases/mozilla-beta/rev/a12fce75b620

aurora:
https://hg.mozilla.org/releases/mozilla-aurora/rev/75399486db0a

when those are done running jobs, I will land the buildbot-configs change, then a reconfig will make actually turn on the tests.
(Assignee)

Comment 18

2 years ago
landed the buildbot-configs:
https://hg.mozilla.org/build/buildbot-configs/rev/d63f07776147
Depends on: 1208959
Armen, please can buildbot patches like this not get r+ until Treeherder has been updated first?
Joel, please can we make sure the Treeherder changes are not forgotten / made after this is already deployed? This has happened several times now - and means sheriffs can't hide jobs properly.

Thanks :-)
(Assignee)

Comment 20

2 years ago
Ed, it is easy to forget this- we cannot test this until it is live, sort of a catch 22 unless you do this all the time.  Can we make treeherder smarter to work with this easier?  Can we have a better process in place for updating all pieces of the system for buildbot changes?  I agree this is frustrating and would be happy to do what is needed if I am aware of it.  Same for when I am reviewing.  A month from now I will forget about it and make the same mistake.
There was no need to test - we were adding a new job, so we needed a new entry in Treeherder - same as last time :-)
I've filed bug 1209109 to make Treeherder just treat these things as hidden so they don't bother the sheriffs.
(Assignee)

Updated

2 years ago
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
Is the summary of this bug a correct reflection of what was checked in?
Flags: needinfo?(jmaher)
(Assignee)

Comment 24

2 years ago
well, it is running successfully on linux64, but we don't run it on other platforms.  I am changing to wontfix.  Thanks for the sanity check!
Flags: needinfo?(jmaher)
Resolution: FIXED → WONTFIX
You need to log in before you can comment on or make changes to this bug.