Closed Bug 119199 Opened 20 years ago Closed 6 months ago

LDAP Address Book does not support multivalued attributes

Categories

(MailNews Core :: Address Book, defect)

defect
Not set
normal

Tracking

(thunderbird_esr78 wontfix)

RESOLVED FIXED
90 Branch
Tracking Status
thunderbird_esr78 --- wontfix

People

(Reporter: john.marmion, Assigned: plucth)

References

(Blocks 1 open bug)

Details

(Whiteboard: nab-ldap)

Attachments

(1 file, 3 obsolete files)

This bug is a spin off from the discussion on bug #118454. LDAP attributes may
contain multiple values. When LDAP entries are displayed in the Address Book
then this factor is not taken into account and instead only the first value is
displayed.
FYI, I don't think this problem was ever addressed in the Communicator 4.x
addressbook either. A lot of users complained about it though.

A related capability which it sounds like you already have implemented is the
ability to use attr1 if it exists but fall back to attr2, e.g., use displayName
if it exists for the Name field but fall back to cn.
QA Contact: nbaca → yulian
mass re-assign.
Assignee: racham → sspitzer
Blocks: 213274
Product: Browser → Seamonkey
Assignee: sspitzer → mail
It would be very useful if multiple "mail" attributes returned by an LDAP query would be honoured. Currently all but the first are discarded, which renders Thunderbird rather useless with servers where both home and business email addresses are held in the "mail" attribute.

Wouldn't it be possible to treat multiple "mail" attributes the same as multiple returned objects for the search for the addressbook and autocompletion, so that users could choose the address they wanted to use, just as if the "second email address" in a Thunderbird contact entry had been specified?
Component: Address Book → MailNews: Address Book
Product: Mozilla Application Suite → Core
Assignee: mail → nobody
QA Contact: yulian → addressbook
With the current autocomplete implementation, it would be possible to fix this for autocomplete only without having to sort out all the addressbook-related issues first.
Product: Core → MailNews Core
Duplicate of this bug: 505810
Duplicate of this bug: 506605
Duplicate of this bug: 250899
Hi,

I know this is an old issue (10 years) but it's still there.

LDAP handling is buggy (you can't see the contacts until you type "." in the search field, multiple email addresses are not handled correctly), there is no SyncML lib, no ActiveSync lib.

Is there a solution to integrate an external address book into thunderbird ? How are we supposed to use external sources ?

This is not pointless criticism but a real question, because today I'm stuck with non-working or partially working solutions :/

Regards

Hi, I am affected by this, and I am gonna try to fix it.

Example changing ldap_2.servers.default.attrmap.SecondEmail for
mail[1] would take the second mail entry for the SecondEmail

Assignee: nobody → plucth
Status: NEW → ASSIGNED

Depends on D99600

Attachment #9192963 - Attachment is obsolete: true

(In reply to Pier-Luc Thériault from comment #11)

Created attachment 9192963 [details]
Bug 119199 - Revert a change needed for an alternative implementation. r=benc

Depends on D99600

I'm so sorry Pier-Luc, but I missed this entirely! (it's only been the last couple of weeks I've started using phab - previously it was all patches attached to the Bugzilla issue).

I don't really understand the address book implications (so I'll foist the review off to darktrojan), but presumably your patch works for you and does what you need, right?

Flags: needinfo?(plucth)

Depends on D99600

Depends on D114590

Attachment #9192883 - Attachment description: Bug 119199 - Make it possible to specify an index in the attribute mapping for address book LDAP directories with multi value attributes. r=benc → Bug 119199 - Make it possible to specify an index in the attribute mapping for address book LDAP directories with multi value attributes. r=darktrojan
Attachment #9220797 - Attachment is obsolete: true
Attachment #9220796 - Attachment is obsolete: true
Target Milestone: --- → 90 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/60400b05b16d
Make it possible to specify an index in the attribute mapping for address book LDAP directories with multi value attributes. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/018a45f6e5e9
followup to fix linting. rs=eslint DONTBUILD
Flags: needinfo?(plucth)
You need to log in before you can comment on or make changes to this bug.