LDAP only shows one LDAP 'mail' attribute.

RESOLVED DUPLICATE of bug 119199

Status

MailNews Core
LDAP Integration
RESOLVED DUPLICATE of bug 119199
14 years ago
8 years ago

People

(Reporter: Paul Bender, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040620
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040620

When a query to an LDAP server returns multiple instances of the 'mail'
attribute, Mozilla only displays one of the instances. This is true in both the
address auto-complete and in the address book search. As a result, when a user
has multiple email addresses, there is no way to select the email address to use.

Reproducible: Always
Steps to Reproduce:
1. Configure LDAP user entry with multiple instances of the 'mail' attribute.
2. Configure Mozilla to use the LDAP server for address matching.
3. Compose email message to the user in step 1.

Actual Results:  
One email address appears for auto-complete in the email message's To field.

Expected Results:  
All email addresses should appear for auto-complete in the email message's To field.
Product: MailNews → Core

Comment 1

13 years ago
(In reply to comment #0)

This looks like a dup of bug 119199

Comment 2

12 years ago
(In reply to comment #1)

Nope. Auto-complete and addressbook aren't the same
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Updated

10 years ago
QA Contact: grylchan → ldap-integration
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 119199
You need to log in before you can comment on or make changes to this bug.