Bug 1192022 (e10s-flashblock)

[e10s] Flashblock add-on compatibility tracker

RESOLVED FIXED

Status

()

Firefox
Extension Compatibility
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mao, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Assignee: Giorgio Maone

Link to add-on: http://flashblock.mozdev.org/

Contact info for add-on: philip.chee@gmail.com

Add-on ID: {3d7eb24f-2740-49df-8937-200b1cc08f8a}

How well does it work?: 50%

Steps to reproduce working features:
* Visit any page containing Flash applets
* Whatch a placeholder replacing any Flash object
* Click on a placeholder to activate the Flash object

Steps to reproduce broken features: 
* See https://bugzilla.mozilla.org/show_bug.cgi?id=1147840#c3

Any obvious performance problems? no

Chromium version: No official, several clones, Chrome has built-in click-to-play for Flash (like Firefox, BTW)

Note: XUL add-on, it uses XBL to implement both the blocking and the placeholder.
Giorgio, how hard do you think it would be to make this work in e10s?
Flags: needinfo?(g.maone)
(Reporter)

Comment 2

2 years ago
(In reply to Bill McCloskey (:billm) from comment #1)
> Giorgio, how hard do you think it would be to make this work in e10s?

"Just" making it work seems feasible, even though everything would break again the day we deprecate XUL, XBL or both.

Migrating on the SDK (or on WebExtensions) is doable but not easy, and if I was the author today I'd probably turn it into a front-end for the built-in Click-to-Play system. And of course, in that case I'd need either require('chrome') or native.js.
Flags: needinfo?(g.maone)
Just to recap from the meeting today, I think it's worth spending a day or two making this work for e10s using XBL.
(Reporter)

Comment 4

2 years ago
(In reply to Bill McCloskey (:billm) from comment #3)
> Just to recap from the meeting today, I think it's worth spending a day or
> two making this work for e10s using XBL.

I'm working on it.
 
The main problem seems to be custom events used in the content side to check for whitelisting being broken in our add-on e10s shims by ES6 proxies:

TypeError: 'preventDefault' called on an object that does not implement interface Event.1 RemoteAddonsParent.jsm:568:0

I doubt this can be easily fixed in the shim itself, as Proxy doesn't forward DOM interfaces by design IIRC: therefore I'm refactoring event handling in a frame script and whitelist checking in a module shared by both processes.

This is taking a while, due to a lot of code duplication (especially for pref caching) and useless legacy stuff, but I should have a working version by this week.
(Reporter)

Comment 5

2 years ago
I've finally hacked together a 1.5.19 release candidate which should fix Bug 1147840, making Flashblock temporarily e10s compatible:

https://bugzilla.mozilla.org/attachment.cgi?id=8657638

I've just asked Philip Chee to review/modify, merge and submit it to AMO.
Giorgio, can you ping Philip again?
Flags: needinfo?(g.maone)
(Reporter)

Comment 7

2 years ago
(In reply to Bill McCloskey (:billm) from comment #6)
> Giorgio, can you ping Philip again?

Done in https://bugzilla.mozilla.org/show_bug.cgi?id=1147840#c8, by private email (you're CC/ed) and through AMO's editorial dashboard.

Also flagging this as needinfo for him.

Philip, are you still maintaining Flashblock?
Have you got any plans for e10s?
Is there anybody else I should try to contact (Lorenzo Colitti, maybe?)
Flags: needinfo?(philip.chee)
Flags: needinfo?(lorenzo)
Flags: needinfo?(g.maone)

Comment 8

2 years ago
I don't think I can reasonably spin a new release, I haven't worked on Flashblock for a very long time.  If Philip cannot be reached, then perhaps we should be looking for another maintainer.
Flags: needinfo?(lorenzo)

Comment 9

2 years ago
I'm still around. Very sorry for the delay leaving NI open

Comment 10

2 years ago
Hi Giorgio! I have multiple reports that Flashblock isn't working in Firefox 42
https://addons.mozilla.org/en-US/firefox/addon/flashblock/#reviews

I must admit I only tested on Nightly (45a1) before sending to AMO
Flags: needinfo?(philip.chee) → needinfo?(g.maone)
(Reporter)

Comment 11

2 years ago
Checking it. 
In the meanwhile, you may want to set the compatibility flags accordingly to the version(s) which are actually working.
Flags: needinfo?(g.maone)
(Reporter)

Comment 12

2 years ago
Created attachment 8695491 [details]
flashblock-1.5.20.xpi

Flashblock 1.5.20, tested on Firefox 38 ESR, Firefox 42 and Nighlty build 20151203053521.
Phil, could you double check and submit it to AMO?
Thanks!
Flags: needinfo?(philip.chee)

Comment 13

2 years ago
Thanks. What changes were needed? Somebody on #extdev suggested that Services.mm is rather new and that I should instantiate the globalmessagemanager directly.
Flags: needinfo?(g.maone)
(Reporter)

Comment 14

2 years ago
(In reply to Philip Chee from comment #13)
> Thanks. What changes were needed? Somebody on #extdev suggested that
> Services.mm is rather new and that I should instantiate the
> globalmessagemanager directly.

That was one change, another was the removing usage of the console object as a global in frame script context (too much recent as well), and lastly there was a bogus usage of the obsolete gFlashblockEnabled variable.
Flags: needinfo?(g.maone)
Hi Giorgio,

I installed this add-on the the latest Aurora release (46.0a2) and it works properly with e10s enabled. I've done this on Windows 7, Windows 10, Ubuntu 14.04 and Mac OS X 10.6.8.
Is this all you wanted to check? Or is there something else you want to do?

Can we consider this as WORKSFORME?

Build ID    20160203004041
User Agent  Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
User Agent  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
User Agent  Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
User Agent  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:46.0) Gecko/20100101 Firefox/46.0

Thanks,
Cipri
Flags: needinfo?(g.maone)
(Reporter)

Comment 16

2 years ago
Thank you Ciprian. It's actually fixed (for now), to be reopened if any other e10s bug is reported.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(philip.chee)
Flags: needinfo?(g.maone)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.