Closed Bug 1192134 Opened 5 years ago Closed 4 years ago

[meta] To fix cppunit orange on emu-x86-kk, TaskCluster

Categories

(Taskcluster :: Services, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla46

People

(Reporter: hsinyi, Unassigned)

References

Details

(In reply to Hsin-Yi Tsai [:hsinyi] from comment #0)
> recent try
> https://treeherder.allizom.org/#/jobs?repo=try&revision=b1cff608589c

error message:

05:22:24     INFO - trying --xre-url
05:22:24     INFO - Downloading --xre-url to /home/worker/build/--xre-url
05:22:24     INFO - retry: Calling _download_file with args: ('--xre-url', '/home/worker/build/--xre-url'), kwargs: {}, attempt #1
05:22:24    FATAL - The file --xre-url does not exist
05:22:24    FATAL - Running post_fatal callback...
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #1)
> (In reply to Hsin-Yi Tsai [:hsinyi] from comment #0)
> > recent try
> > https://treeherder.allizom.org/#/jobs?repo=try&revision=b1cff608589c
> 
> error message:
> 
> 05:22:24     INFO - trying --xre-url
> 05:22:24     INFO - Downloading --xre-url to /home/worker/build/--xre-url
> 05:22:24     INFO - retry: Calling _download_file with args: ('--xre-url',
> '/home/worker/build/--xre-url'), kwargs: {}, attempt #1
> 05:22:24    FATAL - The file --xre-url does not exist
> 05:22:24    FATAL - Running post_fatal callback...
Same root cause as Bug 1192121.
It is because b2g_emulator_cpp_unit.yml requires "test_packages_url"[1] argument, but b2g_emulator_x86_base.yml misses defining "test_packages"[2][3].

[1] https://dxr.mozilla.org/mozilla-central/source/testing/taskcluster/tasks/tests/b2g_emulator_cpp_unit.yml#21
[2] https://dxr.mozilla.org/mozilla-central/source/testing/taskcluster/mach_commands.py#354-360
[3] https://dxr.mozilla.org/mozilla-central/source/testing/taskcluster/tasks/builds/b2g_emulator_base.yml#30

Try Link:
https://treeherder.allizom.org/#/jobs?repo=try&revision=6dc43859f84e
Depends on: 1192125
Summary: To fix cppunit orange on emu-x86-kk, TaskCluster → [meta] To fix cppunit orange on emu-x86-kk, TaskCluster
Depends on: 1201370
cppunit has been enabled by default on various repo. Time to fix this.
Special thanks go to John and Edgar :)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Moving closed bugs across to new Bugzilla product "TaskCluster".
Component: TaskCluster → Integration
Product: Testing → Taskcluster
Target Milestone: --- → mozilla46
Component: Integration → Services
You need to log in before you can comment on or make changes to this bug.