[e10s] Many crashes with varying stacks while loading specific page

RESOLVED DUPLICATE of bug 1189277

Status

()

Core
General
--
critical
RESOLVED DUPLICATE of bug 1189277
2 years ago
2 years ago

People

(Reporter: kats, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

This bug was filed from the Socorro interface and is 
report bp-e98474a5-5e7a-4cf9-a680-043cd2150807.
=============================================================

When loading the page at http://www.rollingstone.com/tv/features/david-letterman-famous-fans-say-goodbye-20150520?page=2 in the latest Nightly on Windows 8.1 I'm consistently getting a child process crash. The stacks are all over the place it looks like. Some reports (the top few are from the latest nightly, the next lot are from a slightly older nightly):

bp-507bdc9e-f5d8-47a2-b13f-cce222150807
bp-eacdba79-0d6e-44ab-a5cf-14d6c2150807
bp-e98474a5-5e7a-4cf9-a680-043cd2150807
bp-4670f68b-e7f1-4d4e-9a12-99ad02150807
bp-5af0c474-7ca2-4cef-a893-2ca842150807
bp-008b6060-07c9-4779-bfc4-c97c92150807
Blocks: 1189916
I'm pretty sure that this is the same crash as bug 1192300.
this is a recent regression according to that reporter
(In reply to Matthias Versen [:Matti] from comment #1)
> I'm pretty sure that this is the same crash as bug 1192300.

Wrong bug number?
sorry, i meant bug 1191661
I ran mozregression-gui and bisected this down to the nightly of 2014-11-07. regression window:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2114ef80f6ae&tochange=b62ccf3228ba

I noticed during bisection that all the e10s builds had this crash and the non-e10s builds did not, so it's quite likely that this crash was introduced on nightly when e10s was turned on by default on nightly.
On the latest nightly with e10s disabled I can't reproduce this crash. With e10s enabled it reproduces 100%.
Summary: Many crashes with varying stacks while loading specific page → [e10s] Many crashes with varying stacks while loading specific page
I re-ran mozregression but this time always opened an e10s window to do the test. This is the regression range I got where the crashes started (nightly of october 22, 2014).

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=29fbfc1b31aa&tochange=ae4d9b4ff2ee

In nightlies prior to october 22, 2014 in my range, loading the URL in an e10s window would not crash, but it would cause firefox to lock up. (i.e. I would open an e10s window, load the URL, scroll around, and close the window - at this point the original non-e10s window would be "Not Responding" and i would have to get windows to terminate the process).
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #6)
> In nightlies prior to october 22, 2014 in my range, loading the URL in an
> e10s window would not crash, but it would cause firefox to lock up. (i.e. I
> would open an e10s window, load the URL, scroll around, and close the window
> - at this point the original non-e10s window would be "Not Responding" and i
> would have to get windows to terminate the process).

... and this behaviour started in the 2014-08-18 nightly. regression range:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=94ba78a42305&tochange=0aaa2d3d15cc

Prior to this with OMTC force-enabled and loading the URL in an e10s window there were no issues.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1189277
You need to log in before you can comment on or make changes to this bug.