Closed Bug 1193029 Opened 6 years ago Closed 5 years ago

[Messages] Blank teal background appears for 1-2 seconds when sharing to messages.

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

RESOLVED DUPLICATE of bug 1228352
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: NicholasN, Unassigned)

References

()

Details

(Keywords: polish, regression, Whiteboard: [2.5-Daily-Testing][Spark][sms-most-wanted])

Attachments

(1 file)

Attached file logcat_messages.txt
Description:
When the user performs a share activity to Messages, a blank teal background appears for 1-2 seconds before the Messages app loads in.


Repro Steps:
1) Update an Aries to 20150810142756
2) Go to gallery and select an image.
3) Tap the share icon and select Messages.


Actual:
Blank teal background appears for 1-2 seconds before Messages app loads in.


Expected:
Messages app opens without blank screen appearing.


Notes:

Environmental Variables:
Device: Aries 2.5
Build ID: 20150810142756
Gaia: fa89e03dc489e79baa0e74cb1d205260c7924caa
Gecko: cd45a38ded04
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


User Impact:


Repro frequency: 4/4
See attached: video clip, logcat
This issue seems to have occurred gradually, and gets less severe moving back from 2.5 to 2.1. The issue does not occur at all on 2.0. 

Flame 2.5

Actual:
Blank teal background appears for 1-2 seconds before Messages app loads in.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150810030209
Gaia: 09dea2d5ff21cdb56da35fe4aa5bf4c90cf1da7f
Gecko: 0e269a1f1beb
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Flame 2.2

Actual:
Blank teal background flashes for an instant when opening Messages from share activity.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150810032504
Gaia: 102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gecko: da29b5af4232
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Flame 2.1

Actual:
Blank teal background appears briefly (slightly longer than 2.2) before Messages app loads in.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150724001207
Gaia: 9dba58d18006e921546cec62c76074ce81e16518
Gecko: 41e10c6740be
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0

Actual Result:

Message app opens without a black background.

Environmental Variables:
Device: Flame 2.0
BuildID: 20150723000207
Gaia: b16ba05481e577bc644ed8966f587a70fe2148e6
Gecko: 2e6f1d4deff9
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 32.0 (2.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
The video is not the "share" activity from Gallery but but "new" activity from Dialer. But I suspect the issue is similar :)

Can you confirm that on 2.2 and 2.1 we don't see the blank background but we do see the "inbox" view before entering the expected panel ?

Can you also please measure whether this is faster/slower/same to enter the expected panel when using the activity ?

Clearly due to bug 1162030.
Blocks: 1162030
Flags: needinfo?(nnelson)
On Flame 2.2 the blank background flashes extremely briefly, and the inbox screen pops up for a short time as well. 

Environmental Variables:
Device: Flame 2.2
BuildID: 20150811123013
Gaia: 102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gecko: 9295034c0ee3
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


On Flame 2.1 the blank screen very briefly flashes, then the inbox view pops up for longer than on 2.2.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150724001207
Gaia: 9dba58d18006e921546cec62c76074ce81e16518
Gecko: 41e10c6740be
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.5 and Aries have a longer blank screen with no inbox view.

I think the activity is taking roughly the same amount of time on each of these branches, but 2.1 and 2.2 flash the blank screen along with the inbox view, whereas 2.5 and Aries just show a teal/white background the whole time.
Flags: needinfo?(nnelson)
Ok thanks, this is exactly as I expected.

Chances are we'll fix this better with NGA.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: polish
[Blocking Requested - why for this release]:
Maybe we'd want this in 2.5 ?
blocking-b2g: --- → 2.5?
Can be fixed, but shouldn't block the release. 

Thanks
blocking-b2g: 2.5? → ---
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark][sms-most-wanted]
Fixed in bug 1228352. Now we display the same color as the header with a fade-in animation, this is much smoother.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1228352
You need to log in before you can comment on or make changes to this bug.