Pref Scoll A Page Up or A Page Down Ignored

VERIFIED FIXED

Status

()

VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: mrmazda, Assigned: mkaply)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
2002010917. OS/2.

A4-Tech WWU-13 USB Trackball.
Microsoft Optical USB Trackball PN X05-87475 PID 52240-576.

Choosing this pref results in same behavior as default setting to scroll one line.
trackball, not mousewheel, right? there are mousewheel preferences, but i'm not
sure if they're applied to trackballs as well...
Assignee: law → jaggernaut
Component: File Handling → XP Toolkit/Widgets
QA Contact: sairuh → jrgm
(Reporter)

Comment 2

17 years ago
How does an app or driver know whether the wheel is on the same side as the
ball? A trackball is nothing but a mouse whose ball gets touched by body parts
instead of a mousepad, and occupies little or no desktop.

Comment 3

17 years ago
everything is dependent on how the driver implements the scrolling features.
(Assignee)

Comment 4

17 years ago
I don't think there is much I can do about scrolling issues because OS/2 does 
not have native mouse scroll support.

Each driver (and application like hotscroll) implement this differently.

If they would just send the window that the mouse is over a WM_HSCROLL or 
WM_VSCROLL, it would work, but most do not.

Most actually simulate arrow keys which is probably what this one does.
(Reporter)

Comment 5

17 years ago
I don't understand the assertion "OS/2 does not have native mouse scroll
support". When I go to OS/2 System -> System Setup -> Mouse, the first tab is
"Scroller". If OS/2 doesn't have native scroll support, where did this settings
tab come from, and why is it there? I'm guessing that it came from XR_C001,
since it is the same file installed as part of either eCS or eCS fixpak 1, and
the mouse.sys in DDFP2 is older still:

Directory of F:\OS2\BOOT

 1-07-02   9:06a     29949           0  MOUSE.SYS
 9-23-00  11:57a     23945           0  MOUSE.SYS.MCP

Updated

17 years ago
QA Contact: jrgm → nobody
(Assignee)

Comment 6

17 years ago
OS/2 scrolling support is implemented by sending up and down arrow 
messages to the window when the mouse is scrolled.

there are no native mouse wheel messages, so the application does not 
know that is is being scrolled by the mouse.

So all we see are arrow key events, not mouse scroll events. This can 
be seen clearly by using a scroll mouse on a WPS folder in icon view.

I'm investigating to see if the mouse driver implementors hid 
something in the arrow messages to let the application know it was 
done by a scroll mouse.

I'll update this bug if I find out anything.
Assignee: jaggernaut → mkaply
(Assignee)

Comment 7

17 years ago
*** Bug 131056 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

17 years ago
If you use the amouse drivers which are available from:

http://www.nbsoftware.de/

And configure it to use scroll messages, all the Mozilla preferences work great.

This is going to be the only supported way of using mouse wheels with Warpzilla, 
since this is the only product that does scrolling the right way (by sending 
scroll messages)

I'll suggest to the OS/2 team that they modify the OS/2 scroll drivers to do 
things the correct way.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 9

17 years ago
I changed my mind :)

We came up with a way to determine if the keystroke is real or not. I can do 
this.

Patch coming.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Assignee)

Comment 10

17 years ago
Created attachment 74359 [details] [diff] [review]
Fix for problem

This is a work of art.

Check the physical key state of the down or up arrow.

If they are not down, assume it is a simulated event from the mouse driver and
scroll the window.
Comment on attachment 74359 [details] [diff] [review]
Fix for problem

r=pedemont if you get rid of the printf
Attachment #74359 - Flags: review+
(Assignee)

Comment 12

17 years ago
Comment on attachment 74359 [details] [diff] [review]
Fix for problem

sr=blizzard (platform specific)
Attachment #74359 - Flags: superreview+
(Assignee)

Comment 14

17 years ago
fix checked in
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

17 years ago
Verified fixed.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 16

17 years ago
I can't figure out how or why I was able to verify this was fixed, as I had been
using a PS/2 trackball with no wheel, and my USB trackball with wheel would not
work at all. I bought a new M$ Intellimouse Optical, and it would not work at
all either, so I uninstalled the AMOUSE driver and rebooted. Now I can use
either USB device, but the wheel won't scroll more than one line at a time no
matter how I configure Mozilla or OS/2. Currently using 2002051916 branch.
Status: VERIFIED → UNCONFIRMED
Resolution: FIXED → ---
(Reporter)

Comment 17

17 years ago
I figured out what happened. I had found a PS/2 wheel trackball to try. My
problem here is OS/2 USB support doesn't work with the AMOUSE driver on my
system. Sorry for the spam.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 18

17 years ago
Reverifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.