Mulet OS X and B2G Desktop OS X package test binaries unnecessarily

RESOLVED FIXED in Firefox 43

Status

()

Core
Build Config
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: jryans, Assigned: jryans)

Tracking

unspecified
mozilla43
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Mulet OS X and B2G Desktop OS X builds from automation, such as the ones in the nightly[1] directory, include many test binaries and files such as "jsapi-tests", "Test<Name>", etc.

Other platforms (win32, linux64) do not include these files in their corresponding builds.

This causes the Mac builds to be 30 - 40 MB larger in compressed archive size than their relatives for other platforms.

[1]: https://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central/
(Assignee)

Comment 1

3 years ago
:mshal, I see that you worked on some packaging and automation tasks for Mulet.  Do you know why this issue is happening?
Flags: needinfo?(mshal)
Does mulet use a package manifest?
(Assignee)

Comment 3

3 years ago
(In reply to Mike Hommey [:glandium] from comment #2)
> Does mulet use a package manifest?

Yes, I believe so.  It appears to use the Firefox one.  Mulet's build.mk[1] includes /browser/build.mk.  /browser/installer/Makefile.in references MOZ_MULET[2], so it would seem likely the Firefox installer and package manifest path are used by Mulet.

[1]: https://dxr.allizom.org/mozilla-central/source/b2g/dev/build.mk
[2]: https://dxr.allizom.org/mozilla-central/source/browser/installer/Makefile.in?offset=100#15
It looks like the tests are being included because of this line:

https://dxr.mozilla.org/mozilla-central/source/b2g/installer/package-manifest.in#35

It's inside the #if XP_MACOSX which is why it only happens on those platforms, and since it's in the b2g manifest we don't see it on Firefox desktop.

:spohl, is the @RESPATH@ line intentional? Why do we want both that (which seems to include everything) and all of the specific @RESPATH@/path/to/file lines in the rest of the manifest?
Flags: needinfo?(mshal) → needinfo?(spohl.mozilla.bugs)
It looks like this should have been changed to @BINPATH@ (instead of @RESPATH@). However, the fact that everything seems to be running normally despite this error makes me think that this line could be removed completely. We may already be packaging all the files under MacOS individually.
Flags: needinfo?(spohl.mozilla.bugs)
(Assignee)

Updated

2 years ago
Blocks: 1198877
(Assignee)

Updated

2 years ago
Assignee: nobody → jryans
Status: NEW → ASSIGNED
(Assignee)

Comment 6

2 years ago
Created attachment 8653094 [details] [diff] [review]
Exclude tests from Mac B2G / Mulet packages

Try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=1c3d6ec9abe4
Attachment #8653094 - Flags: review?(spohl.mozilla.bugs)
Attachment #8653094 - Flags: review?(spohl.mozilla.bugs) → review+
(Assignee)

Comment 7

2 years ago
Created attachment 8653208 [details] [diff] [review]
Exclude tests from Mac B2G / Mulet packages v2

Had to also define LPROJ_ROOT for b2g.

Try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=27c6106f8e91
Attachment #8653094 - Attachment is obsolete: true
Attachment #8653208 - Flags: review+
(Assignee)

Comment 8

2 years ago
Results:

* Simulator XPI: 141 MB -> 96 MB: 45 MB saved
* Mulet DMG: 162 MB -> 73 MB: 89 MB saved

\o/
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/053d760eb1cf
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox43: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla43

Comment 11

2 years ago
I found Simulator on MacOS breaks after this commit, should we backout here?
Flags: needinfo?(jryans)

Comment 12

2 years ago
(In reply to Evelyn Hung [:evelyn] from comment #11)
> I found Simulator on MacOS breaks after this commit, should we backout here?

by "breaks" I mean WebIDE couldn't launch the installed xpi.

I followed the instruction here to build the xpi:
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS/Developing_Gaia/Running_custom_builds_in_WebIDE#Building_a_custom_b2g_binary
(In reply to Evelyn Hung [:evelyn] from comment #11)
> I found Simulator on MacOS breaks after this commit, should we backout here?

Sorry for the trouble.  I can reproduce.  I'll either post a fix or back this out by the end of the day.
Flags: needinfo?(jryans)
(Assignee)

Updated

2 years ago
Depends on: 1201672
(In reply to Evelyn Hung [:evelyn] from comment #11)
> I found Simulator on MacOS breaks after this commit, should we backout here?

I'll resolve this in bug 1201672.
Depends on: 1204170
You need to log in before you can comment on or make changes to this bug.