If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Need better handling when new jobs types and groups are ingested incorrectly the first time

RESOLVED DUPLICATE of bug 1215587

Status

Tree Management
Treeherder: Data Ingestion
P3
normal
RESOLVED DUPLICATE of bug 1215587
2 years ago
a year ago

People

(Reporter: camd, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
Sometimes jobs are posted to Treeherder with incorrect data, like a type in the group name, then it is corrected and it's posted with the fixed group name.  But chunks that were posted with the bad group name the FIRST time, will continue to use that typo'd group.  

We need a way to easily either fix the broken group, or use the new, corrected group going forward.

See Bug 1188987 for an example of this happening.  In that case, I just corrected the problem directly in the DB because that was fastest and simplest.  But we need a better long-term solution to this.
(Reporter)

Updated

2 years ago
Blocks: 1081600, 1188987

Updated

2 years ago
No longer blocks: 1081600
Duplicate of this bug: 1081600
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1166118
(Reporter)

Comment 3

2 years ago
Note: check bug 1166118 as one test case of this happening.

Updated

2 years ago
Priority: -- → P2

Comment 4

2 years ago
Bug 1241280 is an instance of this (IIUC). Could I please get some help to get that instance fixed? Thanks

Updated

2 years ago
Priority: P2 → P3

Updated

a year ago
Blocks: 1284557
I feel like this problem would just go away if we fixed bug 1215587.

Comment 6

a year ago
+1
(Reporter)

Comment 7

a year ago
Wlach: yep, it would.  Bug 1215587 is on my list to fix this quarter.  This bites us enough times that we can't/shouldn't live with it any longer.

We can close this bug as a dup of 1215587.  That one is the real issue.  This would have just been a band-aid.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1215587
You need to log in before you can comment on or make changes to this bug.