Clicking on the icon to mute then unmute (or unmute then mute) without moving the mouse off the icon switches tabs

VERIFIED FIXED in Firefox 42

Status

()

Firefox
Tabbed Browser
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: jaws, Assigned: jaws)

Tracking

unspecified
Firefox 43
Points:
---

Firefox Tracking Flags

(firefox42+ verified, firefox43 verified)

Details

Attachments

(1 attachment)

Clicking on the icon to mute then unmute (or unmute then mute) without moving the mouse off the icon switches tabs.

We shouldn't switch tabs if the audio icon is being clicked. I think this is the result of the `_overPlayingIcon` becoming false when the button is clicked, and it not being true when the icon is clicked a second time causing the tab to get switched to.
Created attachment 8647017 [details] [diff] [review]
Patch

I ran browser/base/content/test/general/browser_tabAudioIcon.js locally.
Browser Chrome Test Summary
        Passed: 86
        Failed: 0
        Todo: 0
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #8647017 - Flags: review?(gijskruitbosch+bugs)
[Tracking Requested - why for this release]:
Tab audio icons are shipping in 42, and I want to make sure this doesn't get forgotten.
tracking-firefox42: --- → ?
Duplicate of this bug: 1192974

Comment 4

2 years ago
Comment on attachment 8647017 [details] [diff] [review]
Patch

Review of attachment 8647017 [details] [diff] [review]:
-----------------------------------------------------------------

Nice!
Attachment #8647017 - Flags: review?(gijskruitbosch+bugs) → review+
Keywords: checkin-needed

Comment 5

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/d63ef58573ca
Keywords: checkin-needed
Backed out for bustage:

https://hg.mozilla.org/integration/fx-team/rev/0ab25f8c278f

TEST-UNEXPECTED-FAIL | unknown test url | uncaught exception - TypeError: soundPlayingIcon is null at chrome://browser/content/tabbrowser.xml:5880

(and similar other failures)

Comment 7

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/879d3f7ab245
https://hg.mozilla.org/mozilla-central/rev/879d3f7ab245
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox43: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Jared, do you want to uplift this to Aurora?
Flags: needinfo?(jaws)
Comment on attachment 8647017 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: icon for tab audio
[User impact if declined]: various bugs related to the icon not responding to clicks or tabs becoming unselectable
[Describe test coverage new/current, TreeHerder]: automated tests cover tab audio indicator
[Risks and why]: none expected, removes some manual state tracking
[String/UUID change made/needed]: none
Flags: needinfo?(jaws)
Attachment #8647017 - Flags: approval-mozilla-aurora?
New feature, tracking it.
tracking-firefox42: ? → +
Comment on attachment 8647017 [details] [diff] [review]
Patch

Want the new feature polished.
Attachment #8647017 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/76f8cfa41d91
status-firefox42: affected → fixed
Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.9.5 using Aurora 42.0a2 (buildID: 20150818004007) and Nightly 43.0a1 (buildID: 20150818030209).
Status: RESOLVED → VERIFIED
status-firefox42: fixed → verified
status-firefox43: fixed → verified

Updated

a year ago
Duplicate of this bug: 1190770
You need to log in before you can comment on or make changes to this bug.