Closed Bug 1193865 Opened 5 years ago Closed 5 years ago

Implement new module (AboutNewTab.jsm) to communicate with remotely hosted newtab pages

Categories

(Firefox :: New Tab Page, defect)

43 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1021654
Iteration:
43.3 - Sep 21
Tracking Status
firefox43 --- affected

People

(Reporter: oyiptong, Unassigned)

References

(Blocks 1 open bug)

Details

The idea of the remotely hosted new tab page is to move more functionality out of a privileged context to a web context, using web technologies to help us.

As such, a lot of functionality is moving to the "client-side". As a reflection of that, we are replacing the current NewTabUtils.jsm and upcoming AboutNewTab.jsm with a new module.

This module will observe to History events, as per NewTabUtils.jsm, as well as some pref changes, to keep sync functionality working.

This module will re-use NewTabUtils.jsm's PlacesProvider, however it will send the raw data, i.e. top 100 frecent sites, to the remotely hosted page.

DirectoryLinksProvider.jsm will cease to exist and will be moved to the remotely hosted page, the download functionality handled by a service worker.
Summary: Implement new module to communicate with remotely hosted newtab pages → Implement new module (AboutNewTab.jsm) to communicate with remotely hosted newtab pages
Repurposing this bug, as it's being broken down.

AboutNewTabUtils.jsm will be the central point of contact with the content processes.
It will either receive method invocations from multiple observers, or from content processes and will marshal the communications with those objects.
Depends on: 1183206
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1021654
You need to log in before you can comment on or make changes to this bug.