Make about:newtab independent of Firefox

RESOLVED FIXED

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: emtwo, Assigned: emtwo)

Tracking

(Blocks: 4 bugs)

40 Branch
Points:
13
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 5 obsolete attachments)

(Assignee)

Description

3 years ago
This includes (but isn't limited to) the following:

1) Removing #ifdef or other pre-processor directives
2) Using window.postMessage instead of RemotePageManager for message passing.
3) Add message passing or find alternatives for Firefox-specific APIs used such as Services.jsm
(Assignee)

Comment 1

3 years ago
Created attachment 8632925 [details] [diff] [review]
WIP: Communication between iframe with about:newtab content and browser
(Assignee)

Comment 2

3 years ago
Newtab code that will be hosted can be found here: https://github.com/emtwo/remote-newtab
(Assignee)

Comment 3

3 years ago
Created attachment 8637473 [details] [diff] [review]
WIP 2: Communication between iframe with about:newtab content and browser
Attachment #8632925 - Attachment is obsolete: true
There's a lot of e10s work (i.e. bug 1021654) going on with about:newtab, you folks should coordinate.
(Assignee)

Comment 5

3 years ago
(In reply to Tim Taubert [:ttaubert] from comment #4)
> There's a lot of e10s work (i.e. bug 1021654) going on with about:newtab,
> you folks should coordinate.

We are co-ordinating with Ursula and Mike who are currently involved in bug 1021654 and I'm personally following that bug closely.

Everything in this bug is being built on top of bug 1021654.
Depends on: 1021654
(In reply to Marina Samuel [:emtwo] from comment #5)
> We are co-ordinating with Ursula and Mike who are currently involved in bug
> 1021654 and I'm personally following that bug closely.
> 
> Everything in this bug is being built on top of bug 1021654.

That's great to hear, sorry for assuming otherwise. Didn't see a lot of e10s folks CC'ed here :)

Updated

3 years ago
Iteration: --- → 42.3 - Aug 10
Points: --- → 5

Updated

3 years ago
Duplicate of this bug: 1180298
(Assignee)

Comment 8

3 years ago
Created attachment 8645156 [details] [diff] [review]
WIP 3: Communication between iframe with about:newtab content and browser
Attachment #8637473 - Attachment is obsolete: true
(Assignee)

Comment 9

3 years ago
Created attachment 8647029 [details]
WIP 4: Communication between iframe with about:newtab content and browser
Attachment #8645156 - Attachment is obsolete: true
(Assignee)

Comment 10

3 years ago
Created attachment 8647513 [details] [diff] [review]
WIP 5: Communication between iframe with about:newtab content and browser
Attachment #8647029 - Attachment is obsolete: true
(Assignee)

Comment 11

3 years ago
Let's include converting to promise messages and re-organizing js files as part of this bug.

We agreed on 3 subdirs of js:

./js/page (UI)
./js/backend (Service worker)
./js/lib (external libraries, tools, helper functions)

Updated

3 years ago
Blocks: 1195113
Points: 5 → 13
Blocks: 1193865
(Assignee)

Comment 12

3 years ago
Created attachment 8651922 [details] [diff] [review]
WIP 6: Communication between iframe with about:newtab content and browser
Attachment #8647513 - Attachment is obsolete: true

Updated

3 years ago
Blocks: 1198204
(Assignee)

Comment 13

3 years ago
This bug is resolved with the following commits:

https://github.com/mozilla/newtab-dev/commit/c8c6a496742e2a31c917a47b35e449a7fbbf7b9
https://github.com/mozilla/remote-newtab/compare/9ecf0d7...019cb8aa
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Blocks: 1202820

Updated

3 years ago
No longer blocks: 1202820

Updated

3 years ago
Blocks: 1202820

Updated

3 years ago
Blocks: 1205313

Updated

3 years ago
No longer blocks: 1205313
You need to log in before you can comment on or make changes to this bug.