Default browser settings missing in Firefox 42 & 43

RESOLVED FIXED in Firefox 42

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: markus.popp, Assigned: glandium)

Tracking

({regression})

42 Branch
Firefox 43
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 unaffected, firefox42+ fixed, firefox43+ fixed)

Details

Attachments

(2 attachments)

Reporter

Description

4 years ago
In Firefox 42.0 and 43.0 there are no longer any options to make Firefox the default browser and to check if Firefox is the default browser in the General panel of the Preferences. I also couldn't find them anywhere else.

I observed this in the Linux64 versions of Firefox, running on Xubuntu 15.04. This may or may not affect other platforms too.

There was a conversation on Twitter about this issue prior to me filing this bug report: https://twitter.com/mpopp75/status/631595763437584384

Comment 1

4 years ago
[Tracking Requested - why for this release]: Unable to make default browser, regression since Firefox42

Updated

4 years ago
Keywords: regression

Comment 2

4 years ago
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1ee54e043b9b&tochange=939320b957c5

Regressed by: 939320b957c5	Mike Hommey — Bug 1186003 - Switch automated builds to Gtk+3. r=mshal

Updated

4 years ago
Flags: needinfo?(mh+mozilla)
Assignee

Updated

4 years ago
Blocks: gtk3
Flags: needinfo?(mh+mozilla)
Assignee

Updated

4 years ago
Blocks: 879760
No longer blocks: 1186003
Assignee

Updated

4 years ago
Assignee: nobody → mh+mozilla
Assignee

Comment 3

4 years ago
This is the trivial fix for this.
Attachment #8653839 - Flags: review?(karlt)
Comment on attachment 8653839 [details] [diff] [review]
Set HAVE_SHELL_SERVICE when preprocessing in-content prefs on Gtk+3 builds

There was I assuming we'd finally fixed the nagging :)
Attachment #8653839 - Flags: review?(karlt) → review+
Assignee

Comment 6

4 years ago
Comment on attachment 8653839 [details] [diff] [review]
Set HAVE_SHELL_SERVICE when preprocessing in-content prefs on Gtk+3 builds

Approval Request Comment
[Feature/regressing bug #]: Regression from the combination of bug 879760 and bug 1186003.
[User impact if declined]: In-content preferences don't have the items to set Firefox as default browser (non in-content prefs do, however, but they're not enabled by default)
[Risks and why]: Very low. The patch is a simple thing that was forgotten in bug 879760. browser/components/preferences/moz.build had this change done for non in-content prefs, which is why it still works. This makes in-content prefs on-par with that.
[String/UUID change made/needed]: None
Attachment #8653839 - Flags: approval-mozilla-aurora?
Important regression, tracking.
https://hg.mozilla.org/mozilla-central/rev/93052c1a0e48
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Attachment #8653839 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.