If this is possible, put a close and a cancel button with Firefox preferences dialog

RESOLVED DUPLICATE of bug 1129947

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 1129947
3 years ago
3 years ago

People

(Reporter: Attila Hammer, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150807094952

Steps to reproduce:

1. Launch Firefox.
2. Open preferences menu. This situation in Firefox 40.0 release presents the about:preferences local webpage (the preference dialog pane). Try changing some preferences temporary.
3. Try closing this dialog only with keyboard when using normal dialog navigation operation keys (TAB, SHIFT+TAB, Space or ENTER keystrokes). I not founded any buttons with provide possibility to close and apply the new changed preferences, or revert the changed preferences. Possible this dialog have close or cancel buttons, I am not full sure this. I using Firefox only with Orca screen reader and not seeing visually the dialog screen.


Actual results:

If anybody not known the CTRL+W keystroke, only possible to close this dialog with ALT+F4 keystroke, but this keystroke closing entire Firefox window if the user want closing all opened tabs.


Expected results:

If this is fit Firefox UI design, please put a Cancel and a Close buttons this dialog pane. If this change acceptable, please add a mnemonic letter this two new buttons.
(Reporter)

Updated

3 years ago
Component: Untriaged → Disability Access

Comment 1

3 years ago
Gijs, is there a way to dismiss the preferences without making any changes using the mouse?
Component: Disability Access → Preferences
Flags: needinfo?(gijskruitbosch+bugs)

Comment 2

3 years ago
All the changes are applied immediately (like on OS X). So there is no "cancel" button. I don't think we want to add one - part of the goal was to make the preferences more intuitive and make settings changes apply immediately.

To dismiss the preferences, you would close the tab, or navigate somewhere else in the same tab. Basically the same thing you would normally do to leave a webpage. There are several keyboard-accessible ways of doing this, and the situation with the mouse is the same - there are no "hidden" cancel buttons or something like this.

I don't think this is an accessibility issue per se. It's essentially a request that we make the preference pane not apply changes immediately, and to use the "usual" ok/cancel/apply buttons on Windows. I don't think we want to do that, but even so, it's probably a duplicate of bug 1129947.
Flags: needinfo?(gijskruitbosch+bugs)
(Reporter)

Comment 3

3 years ago
Gijs, the problem is following only with keyboard usage:
For example, you opened the preferences dialog.
Uncheck the "open new windows with new tab" check box.
If you press ALT+F4 keystroke, the preference is keeped. Launch Firefox again, and open preference pane and verify.
If you press CTRL+W keystroke to close the preferences page tab, the preference is keeped.
How you dismiss this unchecked check box preference if you not would like keeping this change?
Hopefully I translated right english the example check box label.
If the preference pane future have a Close and a Cancel button, Cancel button not possible reverting the applied preferences?
The close button of course need keeping the changed preferences.
Me not problem if need closing the preference pane for example with CTRL+W keystroke because using day by day with Firefox, but if anybody not known perfect with Firefox shortcuts (have big chance this a beginner Firefox user if using only with keyboard), this two buttons easying with Firefox preference pane usage.
I think oldest time in Firefox preference pane have a close button, similar with Thunderbird. Now, only the help button have the preference pane and I think the close button is removed.
Not only Windows platform affected unfortunatelly, I tested this working method in Linux.

If not fitting this traditional preference pane change with Firefox new UI interface, I agree if anybody closing this bug.

Attila

Comment 4

3 years ago
I do not think the old preferences dialog will come back, and thus no Cancel and OK/Close buttons. Marking this as a duplicate as Gijs suggests in comment #2.

The issue that Alt+F4 doesn't preserve settings is an issue for a different bug that would need exact steps to reproduce and should be filed separately. That is also not an accessibility issue, rather one of the Preferences tab functionality.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1129947
You need to log in before you can comment on or make changes to this bug.