Closed Bug 1129947 Opened 5 years ago Closed 4 years ago

Provide undo UI for in-content preferences at least.

Categories

(Firefox :: Preferences, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression, ux-consistency, ux-undo)

Bug 1037225 is landed. However, the prefs in about:config seems to be changed instantly when I changed the related items in in-content preferences.

And It is not consistent across the main preferences panels and the sub-dialog(incl. add-ons's dialog).

I ask "ux-undo" and "ux-consistency"  User experience principle.
Blocks: 1037225
"ux-consistency" point of view, this is a regression from non inContent preferences
Keywords: regression
The main in-content prefs applying instantly, with the dialogs having OK/Cancel buttons and add-ons not being affected are all design goals. If you think one of those things is wrong, please write to firefox-dev instead. We're not going to revert it merely for reasons of consistency. This is also not really related to bug 1037225, which didn't really change this.

Add-ons can themselves choose how prefs are implemented; the ones that use prefs inside the addons manager have been doing this (instant-apply prefs) on Windows for ages, too (e.g. adblockplus).

It's not clear to me what this bugreport is asking for. The changes are "instantapply" for undo as well, so if you tick, say, "open new windows in a new tab instead", you can just untick it again... What kind of undo functionality do you want, and why do you think it's necessary?
No longer blocks: 1037225
Flags: needinfo?(alice0775)
Addon's one is the addon Bug. I think add-on author should honor the instant-apply prefs.
The adblock addon author ignores the instant-apply prefs. I think that this is not good.

Firefox of UI and The bad add-on is another issue entirely. 



Now, the in-content preference UI chages the prefs instantly. In this case , I think undo UI should be provided.

The most desirable, the in-content preference UI should also be honor the instant-apply prefs.
Flags: needinfo?(alice0775)
No longer blocks: ship-incontent-prefs
OS: Windows 7 → All
Hardware: x86_64 → All
Blocks: 718011
Duplicate of this bug: 1194047
@Tim,
I am not sure a "Undo" button/UI has its use case in the in-content design.
Whom we could turn to to review this, UX or Product?
Thanks
Flags: needinfo?(timdream)
Per discussed in our meeting, let's make defer the decision to UX.
Flags: needinfo?(timdream)
@Tina & Jack,
Please check this bug and let us know if this "Undo" button/UI is really necessary in the Preference page design, thanks.
Flags: needinfo?(thsieh)
Flags: needinfo?(jalin)
Hi all,

I think "Undo" in Add-ons Manager is a reminder to remind you that some important function will be removed. So it makes sense that show a "Undo" button to double confirm your decision. And if you regret, you can easily cancel the decision. I would like to say is it's hard to get the removed item back, so double confirm is necessary.

And setting in Preference is like 'enable or disable a function' or 'choose your habbit'. If you want to cancel your dicision, just click the check box again or select the item you want. So, there is no necessary to provide users "Undo" button. Moreover, if we have "Undo" button next to each item, the readability of Preference page will be complicated.

So I suggest no "Undo" button on the Preference page.

Thank you
Flags: needinfo?(jalin) → needinfo?(fliu)
Mark as WONTFIX because currently there is no use case for an "Undo" button inside the Preference page based on Comment 8 from UX team.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(fliu)
Resolution: --- → WONTFIX
Flags: needinfo?(thsieh)
You need to log in before you can comment on or make changes to this bug.