Closed Bug 1194062 Opened 6 years ago Closed 9 months ago

[PDF Viewer] pdf.js has a unsupported layer problem

Categories

(Firefox :: PDF Viewer, defect, P3)

40 Branch
defect

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox40 --- wontfix
firefox41 --- wontfix
firefox42 --- wontfix
firefox43 --- wontfix
firefox44 --- wontfix

People

(Reporter: maesilgim, Unassigned)

References

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-layers])

Attachments

(1 file)

Attached image problem pdf.png
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150806001005

Steps to reproduce:

1. go to Seibu Railway map.[1] 
[1] http://www.seibu-group.co.jp/railways/railway/rosen/__icsFiles/afieldfile/2013/03/14/pdf_ikb_130316.pdf


Actual results:

Japanese letter(Kanji, Hiragana, Katagana, etc.) is shown doubled. I attached what happened when I read Seibu Railway Map.(problem pdf.png)

When I change size of page(like 100%, 170%, etc.), it is shown normally but instantly it changed and shown doubled. 


Expected results:

It should shown not doubled. When I read this pdf file with TWINUI(Windows 8 pdf reader) I can see normally.
Component: Untriaged → PDF Viewer
I tested this with firefox 39.0.3 and Firefox Developer Version 41.0a2(2015-8-10) but both has problem.
Version: 39 Branch → 40 Branch
I also tested this with Firefox 40 now but it has same problem.
It appears to be a layer issue which we don't support. (Preview on OSX also does not support this).
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-layers]
Summary: problem showing japanese in pdf file → [PDF Viewer] pdf.js has a unsupported layer problem
Depends on: 882383
(Bug 882383 is about a different type of layers, so unrelated to this bug.)
No longer depends on: 882383
Duplicate of this bug: 1585400
Duplicate of this bug: 1586547
Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Depends on: 1657400
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Duplicate of this bug: 845650
Duplicate of this bug: 846407
Duplicate of this bug: 1085042
Duplicate of this bug: 1240641
Duplicate of this bug: 1660788
You need to log in before you can comment on or make changes to this bug.