Closed Bug 1194084 Opened 9 years ago Closed 6 years ago

[e10s] Kaspersky Protection add-on compatibility tracker

Categories

(Firefox :: Extension Compatibility, defect)

defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox43 --- affected

People

(Reporter: ma1, Unassigned)

References

()

Details

Assignee: Giorgio Maone

Link to add-on: http://www.kaspersky.com/internet-security

Contact info for add-on:  http://www.kaspersky.com/

Add-on ID: light_plugin_D772DC8D6FAF43A29B25C4EBAA5AD1DE@kaspersky.com

How well does it work?: 100%

Steps to reproduce working features:
* Perform a Goolge search and hover on the small icons added by the extension near search results to rate their "safety"
* Push the toolbar icon to access its "Ghostery-like" features

Steps to reproduce broken features: N/A

Any obvious performance problems? no

SDK Add-on: Yes

Chromium version: Yes

Notes: 
* It injects in every page scripts from https://ff.kis.scr.kaspersky-labs.com/ pointing to a local webserver and makes a lot of XHR requests to the same host. This may become problematic with CSP (even though the extension itself apparently injects its own CSP configuration) and if/when LAN CSRF protection gets implemented (already blocked by ABE's, for instance).

* Not signed on AMO (yet?), had to override xpinstall.signatures.required
See Also: → 1381464
With WebExtensions being the only valid way of doing extensions in Firefox 57, I don't think this bug is still relevant.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.