[v2.5][Gaia::UI Tests]test_homescreen_status_bar_icons_visibility.py: "AssertionError: False is not true"

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
4 years ago
Last year

People

(Reporter: liuke, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-master affected)

Details

Attachments

(1 attachment)

[Description]
test_homescreen_status_bar_icons_visibility.py fails

[Steps to Reproduce]
test_homescreen_status_bar_icons_visibility.py

[Reproduction Frequency]
Always, 5/5

[Reproducible manually]
NO

Traceback (most recent call last):
File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.16-py2.7.egg/marionette/marionette_test.py", line 296, in run
testMethod()
File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/homescreen/test_homescreen_status_bar_icons_visibility.py", line 32, in test_homescreen_status_bar_icons_visibility
self.assertTrue(status_bar.maximized.is_battery_displayed)
AssertionError: False is not true

[Build info]
Device firmware (base) 	L1TC000118D0
Device firmware (date) 	12 Aug 2015 18:24:21
Device firmware (incremental) 	eng.cltbld.20150812.062410
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	12 Aug 2015 02:18:36
Gaia revision 	c7875bbc8b32
Gecko build 	20150812030210
Gecko revision 	d4f3a8a75577e4af2914a4e899ca2e724f9715c4
Gecko version 	43.0a1

[Attachments]
20150812030210_SMOKETEST.html
This works for me locally, using:
Build ID               20150813030210
Gaia Revision          52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gaia Date              2015-08-12 16:40:43
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150727.063909
Firmware Date          Mon Jul 27 06:39:20 EDT 2015
Bootloader             L1TC000118D0

On bitbar it's passing too: http://jenkins1.qa.scl3.mozilla.com/view/Bitbar/job/flame-kk-319.b2g-inbound.tinderbox.ui.functional.smoke.bitbar/2519/console

So I really wonder why it's failing there, wherever this automated test is run. The screenshot shows the statusbar and the battery icon just fine.
Johan, I heard you were able to VPN in the automation lab of Marigold, so I guess you can investigate this issue?
Flags: needinfo?(jlorenzo)
I used to have access to [1], but I just tried and my browser times out. Paul, is it something you can help with?

[1] mtbf-2.corp.tpe1.mozilla.com
Flags: needinfo?(jlorenzo) → needinfo?(pyang)
I see that the test is failing on b2g desktop, at least: https://s3-us-west-2.amazonaws.com/taskcluster-public-artifacts/6-XUFWgtTTKnPOgwKOuKkg/2/public/gaia_ui_tests/gaia_ui_tests_report.html
So I guess this should be skipped for desktop, although not sure how much we still care for this.
NI? test creator to see this.
Flags: needinfo?(luis)
Blocks: 1100411
(In reply to Paul Yang [:pyang] from comment #5)
> NI? test creator to see this.

Ok, skipping it for desktop woukd be ok?
Flags: needinfo?(luis)
(In reply to lusob from comment #6)
> (In reply to Paul Yang [:pyang] from comment #5)
> > NI? test creator to see this.
> 
> Ok, skipping it for desktop woukd be ok?

The problem is that this also occurs on the Flame devices in the Marigold lab, aparently. I haven't seen this happening here locally and it doesn't happen in the Mountain View lab or in Bitbar, afaik.

I noticed on b2g desktip, for some reason, minimized is displayed, as opposed to maximized:
https://github.com/mozilla-b2g/gaia/blob/52f3ea58df38e5427f6afeb636bc6ad01d24022f/tests/python/gaia-ui-tests/gaiatest/apps/system/regions/status_bar.py#L20
        """
        Status bar in its minimized form. When the RocketBar is at the same level with the connectivity icons.
        Usually seen when a app is open
        """
No idea why this is happening on b2g desktop (and presumably on Marigold Flame too), but it seems like a bug to me.
clear ni? per explaining in comment 7
Flags: needinfo?(pyang)
(In reply to Paul Yang [:pyang] from comment #8)
> clear ni? per explaining in comment 7

I can't reproduce the bug on my environment so I don't know how to fix it..., any clue?
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.