Closed Bug 1194328 Opened 4 years ago Closed Last year

FF40 made weird changes in menubar colors

Categories

(Firefox :: Theme, defect)

40 Branch
Unspecified
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1198538

People

(Reporter: kirinyale, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Attached image ff40_menubar.png
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150807085045

Steps to reproduce:

Launch Firefox 40 on Windows 10 x64 with menubar enabled.


Actual results:

See attached screenshot.

Window title is white, menubar is 2 different shades of gray (lighter under the actual menus, darker to the right from them), everything below it is another different shade of gray. And when FF is unfocused, the whole menubar changes color to yet another darker shade of gray.


Expected results:

Single color for titlebar and menubar, like in FF39 and before. Changing titlebar to Win10's default white is fine by itself, but together it just looks weird and ugly now.
Blocks: windows-10
Component: Untriaged → Theme
OS: Unspecified → Windows 10
Where is your tabbar, and can you reproduce this and provide screenshots on a clean profile?
Flags: needinfo?(kirinyale)
I'm sorry that I can't take new screenshots on Win10 at the moment (since I reverted to 8.1 due to general instability of the OS) - I'll add them if I get the chance on some other PC soon.

For now, I'm attaching a screenshot from Win8.1. This is how it looks for me on FF 40.0.2 in safe mode or on fresh profile (after enabling menu-bar and disabling "browser.tabs.drawInTitleBar" option in about:config. This (Win8.1) behavior is exactly what I expect, but for some reason it was different in Win10. Note that normally I'm running FF with "classic theme restorer" extension, so perhaps it makes the issue more obvious, but it doesn't look like it's the root case.

The problem seems to be that title bar color is for some reason different from both menu bar and tabs background in Win10, while they are still the same in Win8.1.
Flags: needinfo?(kirinyale)
Attached image ff40_win81_classic.png
Adding another screenshot of how it looks like with my usual settings (classic theme restorer enabled). Still fine with Win8.1.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1198538
You need to log in before you can comment on or make changes to this bug.