Closed Bug 1194363 Opened 6 years ago Closed 5 years ago

The code area in event listener popup is sometimes too narrow compared to width of popup itself.

Categories

(DevTools :: Inspector, defect, P3)

defect

Tracking

(firefox43 affected)

RESOLVED FIXED
Tracking Status
firefox43 --- affected

People

(Reporter: arni2033, Unassigned)

References

()

Details

Attachments

(1 file)

STR (A):
1. Open page   data:text/html,<a oncut>
2. Open Devtools->Inspector, inspect <body>
3. Press (ev) button near <a> element

Result:       The code area in event listener popup doesn't take all place of popup
Expectations: They should have the same width

Note: I also have another examples of this:
(B)
1. Open page   data:text/html,<body>
2. Open Inspector
3. Open Scratchpad, execute this: document.body.onclick=()=>{}
4. Reopen Inspector, press (ev) button near <body> element
(C)
1. Open about:preferences
2. Find element #browserHomePage > [class="autocomplete-textbox-container"] > [class="textbox-input-box"] > [anonid="input-box-contextmenu"]
(Note that you can't find it using "Search by CSS selectors". Only manually.)
3. Press (ev) button near that element
Severity: normal → trivial
(D)
1. Open http://www.s3fox.net/
2. Open Inspector, paste "img[onmouseout]" (without quotes) into field "Search with CSS selectors"
3. Click (ev) button near found <img> element.
This issue appears for every site having short URL if eventListeners are declared as attribute
See Also: → 1082502
Blocking this on the HTML migration of the event popup.

Inspector bug triage. Filter on CLIMBING SHOES.
Depends on: 1266450
Priority: -- → P3
@arni2033: I believe this is fixed now... is it working for you?
Flags: needinfo?(arni2033)
I can't test any version later than 2016-05-26 due to bad internet connection, but I remember testing this on Nightly 2016-10-01, and XUL panel was replaced with a broken (bug 1279400) HTML replacement
However, the HTML replacement fixed the styling, so this bug wasn't reproducible.

If it's still the case on Nightly and if you already pushed the broken HTML replacement to release version, then this bug can't possibly happen. Set NI again if you want me to test the latest Nightly
when I get back my internet connection.
Flags: needinfo?(arni2033)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.