Fix devtools-tooltip-events-container style and behavior

RESOLVED DUPLICATE of bug 1278181

Status

()

Firefox
Developer Tools: Inspector
P3
normal
RESOLVED DUPLICATE of bug 1278181
2 years ago
a year ago

People

(Reporter: magicp, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8761894 [details]
devtools-tooltip-events-container-aurora-vs-nightly.png

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160609130607

Steps to reproduce:

1. Start latest Nightly
2. Go to about:home
3. Open devtools > Inspector
4. Click markupview-events on html element
5. Click any events


Actual results:

devtools-tooltip-events-container is smaller than Aurora, and also its height does not expand vertically when expanding any events. Then two vertical scrollbars will appear.


Expected results:

Apply previous build style and behavior
(Reporter)

Updated

2 years ago
Has STR: --- → yes
status-firefox50: --- → affected
Component: Untriaged → Developer Tools: Inspector
OS: Unspecified → All
Hardware: Unspecified → All
(Reporter)

Comment 1

2 years ago
Regression range:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=63ec66da50faad032454a44d3af3124c35102b3e&tochange=62ad4f6b5c3428e4b33e1e4ba75288c94c45ec92
Blocks: 1266450
Has Regression Range: --- → yes

Updated

2 years ago
Blocks: 1259121
Whiteboard: [devtools-html] [triage]
As we are moving the devtools out of XUL, the tooltips and floating panels are displayed within the toolbox area.
The tooltip actually expands when you open the code previews, but only until it reaches the top/bottom of the toolbox.

Two related bugs:
- Bug 1267403: reuse a XUL panel as a wrapper for the tooltips. Means we could use all the viewport's height and have the same behavior as today.
- Bug 1278181: change the design of the event details tooltip to be more compact. This will probably mean removing the code preview from the tooltip in favor of a more explicit link to open the event handler in the debugger tab.

For now I am going to block this on Bug 1267403. 

magicp: can you comment on Bug 1278181 if you feel strongly against removing the code previews? I'm in favor of removing them but if users find them useful we should reconsider and give more priority to Bug 1267403.
Depends on: 1267403
magicp: see question above.
Flags: needinfo?(magicp.jp)

Updated

2 years ago
Priority: -- → P3
Whiteboard: [devtools-html] [triage] → [reserve-html]
(Reporter)

Comment 4

2 years ago
(In reply to Julian Descottes [:jdescottes] from comment #2)

> magicp: can you comment on Bug 1278181 if you feel strongly against removing
> the code previews? I'm in favor of removing them but if users find them
> useful we should reconsider and give more priority to Bug 1267403.

I'm in favor of removing them too.
Flags: needinfo?(magicp.jp)
Bug 1267403 landed, but unfortunately we cannot use the XUL panel wrapper for the event details tooltip due to a technical issue (logged in Bug 1285261).

This means we will now go ahead with Bug 1278181 and update the design of the event details tooltip in order to be more compact.
Therefore I am closing this bug as a duplicate of 1278181.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1278181
No longer blocks: 1259121
Whiteboard: [reserve-html]
You need to log in before you can comment on or make changes to this bug.