[taskclsuter-vcs] Tar operations should be done serially

RESOLVED FIXED

Status

Taskcluster
General
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: garndt, Assigned: garndt)

Tracking

Details

Attachments

(1 attachment)

54 bytes, text/x-github-pull-request
jonasfj
: review+
Details | Review | Splinter Review
(Assignee)

Description

3 years ago
Currently taskcluster-vcs will attempt to extract all the repo tarballs in parallel causing interesting race conditions.  Tarballs that are extracting to the same parent directories should not be done in parallel
(Assignee)

Comment 1

3 years ago
Created attachment 8647688 [details] [review]
tc-vcs PR 22

So I've ran this a bunch of times with no errors from tar any longer.  It does take abouta  minute longer, but that's a small price to pay for it to be correct.

Also removed the handling of removing corrupted tarballs, this really should be handled by purging worker caches and so far I have yet to see this be an issue.  Perhaps we will see some errors now and be able to attack the root cause.
Attachment #8647688 - Flags: review?(jopsen)
(Assignee)

Updated

3 years ago
Blocks: 1189830
Comment on attachment 8647688 [details] [review]
tc-vcs PR 22

See comments, I think this sound.
But we could potentially do faster.
Attachment #8647688 - Flags: review?(jopsen) → review+
See Also: → bug 1194463
(Assignee)

Comment 3

3 years ago
Merged https://github.com/taskcluster/taskcluster-vcs/commit/b04c6b5b759acd8a0bbe46d92a4eb0b79e1910fa
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Blocks: 1182491
Duplicate of this bug: 1194463
You need to log in before you can comment on or make changes to this bug.