SEGFAULT in mutex.c: File Not found when clicking this link

VERIFIED DUPLICATE of bug 127442

Status

--
critical
VERIFIED DUPLICATE of bug 127442
17 years ago
5 years ago

People

(Reporter: bootsy52, Assigned: dveditz)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:0.9.7+) Gecko/20020111
BuildID:    CVS Jan 11th 2002 CET

Found this bug when I choosed preferences->content packs->download more

when clicking on the link it segfaults.
Compiled on Jan 11th 2002 CET with gcc-2.95.3 and glib-2.2.2
with options#
############################## OPTIONS #################
ac_add_options --prefix=/usr/lib/mozilla-097
ac_add_options --libdir=/usr/lib/mozilla-097
ac_add_options --includedir=/usr/include/mozilla-097
ac_add_options --enable-crypto
ac_add_options --disable-accessibility
ac_add_options --enable-mathml
ac_add_options --enable-svg
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize="-O6 -march=i686 -mcpu=i686"
ac_add_options --disable-dtd-debug
ac_add_options --enable-strip
ac_add_options --with-default-mozilla-five-home=/usr/lib/mozilla-097
ac_add_options --with-user-appdir=.mozilla-097
ac_add_options --enable-static
ac_add_options --disable-shared

###################### END OPTIONS ##########################
and here is the GDB and BACKTRACE 

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1024 (LWP 4908)]
__pthread_mutex_lock (mutex=0x0) at mutex.c:99
99
mutex.c: No such file or directory.
	in mutex.c



#0  __pthread_mutex_lock (mutex=0x0) at mutex.c:99
#1  0x40317183 in PR_Lock () from /usr/lib/mozilla-097/libnspr4.so
#2  0x40950513 in NSGetModule () from
/usr/lib/mozilla-097/components/libxpinstall.so
#3  0x408f7aca in NSGetModule () from
/usr/lib/mozilla-097/components/libxpinstall.so
#4  0x409389c0 in NSGetModule () from
/usr/lib/mozilla-097/components/libxpinstall.so
#5  0x4093a050 in NSGetModule () from
/usr/lib/mozilla-097/components/libxpinstall.so
#6  0x4093a8c3 in NSGetModule () from
/usr/lib/mozilla-097/components/libxpinstall.so
#7  0x4091c6c9 in NSGetModule () from
/usr/lib/mozilla-097/components/libxpinstall.so
#8  0x409328ac in NSGetModule () from
/usr/lib/mozilla-097/components/libxpinstall.so
#9  0x08f11cd3 in js_Invoke ()
#10 0x08f18f6d in js_Interpret ()
#11 0x08f11d26 in js_Invoke ()
#12 0x08f11f25 in js_InternalInvoke ()
#13 0x08eea1bb in JS_CallFunctionValue ()
#14 0x08709ffa in nsJSContext::CallEventHandler ()
#15 0x08732e69 in nsJSEventListener::HandleEvent ()
#16 0x0876495e in nsEventListenerManager::HandleEventSubType ()
#17 0x0876500b in nsEventListenerManager::HandleEvent ()
#18 0x0886644c in nsGenericElement::HandleDOMEvent ()
#19 0x087790d4 in nsGenericHTMLElement::HandleDOMEventForAnchors ()
#20 0x088c2b2e in nsHTMLAnchorElement::HandleDOMEvent ()
#21 0x08861573 in nsGenericDOMDataNode::HandleDOMEvent ()
#22 0x0894ecc5 in PresShell::HandleEventInternal ()
#23 0x08951e3d in PresShell::HandleEventWithTarget ()
#24 0x0876d3ed in nsEventStateManager::CheckForAndDispatchClick ()
#25 0x0876bd77 in nsEventStateManager::PostHandleEvent ()
#26 0x0894ee51 in PresShell::HandleEventInternal ()
#27 0x0894eb17 in PresShell::HandleEvent ()
#28 0x087363c0 in nsView::HandleEvent ()
#29 0x08736340 in nsView::HandleEvent ()
#30 0x08736340 in nsView::HandleEvent ()
#31 0x0873faf2 in nsViewManager::DispatchEvent ()
#32 0x087371c3 in nsView::GetClippedRect ()
#33 0x0875ccff in nsWidget::DispatchEvent ()
#34 0x0875b719 in nsWidget::DispatchMouseEvent ()
#35 0x0875c0a7 in nsWidget::OnButtonReleaseSignal ()
#36 0x08744831 in nsWindow::HandleGDKEvent ()
#37 0x0875801a in handle_scrollbar_value_changed ()
#38 0x087579e3 in handle_gdk_event ()
#39 0x4048fb4f in gdk_event_dispatch (source_data=0x0, current_time=0xbffff560,
user_data=0x0)
    at gdkevents.c:2139
#40 0x404c1030 in g_main_dispatch (dispatch_time=0xbffff560) at gmain.c:656
#41 0x404c166f in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#42 0x404c210b in g_main_run (loop=0x9681c70) at gmain.c:935
#43 0x403d72c3 in gtk_main () at gtkmain.c:524
#44 0x087516bd in nsAppShell::Run ()
#45 0x08bf9703 in nsAppShellService::Run ()
#46 0x08531419 in _start ()
#47 0x08531d6e in main ()
#48 0x405161f0 in __libc_start_main () from /lib/libc.so.6

####################### END #########################################

Reproducible: Always
Steps to Reproduce:
1.choose edit->preferences->content packs->dowload more->click the link
2.
3.

Actual Results:  SEGFAULT (as root as well as normal user)

Expected Results:  No Segfault

Mandrake 8.0
Kernel 2.4.8-ac7

Updated

17 years ago
Keywords: crash

Comment 1

17 years ago
Carsten, are you still seeing this with a recent nightly build? Can you post a
talkback incident ID from the crash?
Assignee: asa → dveditz
Status: UNCONFIRMED → NEW
Component: Browser-General → Installer
Ever confirmed: true
QA Contact: doronr → bugzilla

Updated

17 years ago
QA Contact: bugzilla → ktrina
(Reporter)

Comment 2

17 years ago
As I mailed you privatley due to buggy bugzilla today, yes
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Reporter)

Updated

17 years ago
Keywords: mozilla0.9.9

Comment 3

17 years ago
Content Packs panel has been changed quite a lot recently due to bug 91721, and
the "download more" button was not working for a certain time (bug 126679).

With a recent build from yesterday (2002-03-02) - user agent string (telling all
you need I believe)
Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:0.9.8+) Gecko/20020220
 (btw, why doesn't that say Gecko/20020302 ???)

this works for me!
(Reporter)

Comment 4

17 years ago
Could not Confirm as of Buld March 3rd 2002 the Download Button "Download More"
does not work again. get this error:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIDOMWindowInternal.focus]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://communicator/content/utilityOverlay.js :: openTopWin :: line 254" 
data: no]

Will comment to reopen the bug which concerns this.
(Reporter)

Comment 5

17 years ago
Rebuild with MOZILLA_0_9_9_BRANCH, Dowload button works, but could not produce
second GDB output to show you that Mozilla still crashes on this. Because soon
after gdb run Mozilla segfaults in libxpcom Mozilla does not even start up in
gdb mode.

I'm really not a C programmer, so excuse the dump question, but as this issue is
working for others, could it be, that the crash is caused by my version of glibc ?

Using glibc-2.2.2 on a Mandrake 8.0 otherwise I have no explanation, why I
should be the only one who get this crasher.
(Reporter)

Comment 6

17 years ago
Created attachment 72908 [details]
Recent GDB Output of MOZILLA_0_9_9_BRANCH Build (March 7th)
Duplicate stack trace to 127442; both are static builds.  If you don't think
these are the same, please retest with the fix from that bug.

*** This bug has been marked as a duplicate of 127442 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
Verified as a dupe of bug 127442

Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.