Closed Bug 1194725 Opened 4 years ago Closed 4 years ago

[HiDPI] Nested toolbar buttons (zoom in, zoom out, copy, cut, paste) are oversized when moved to a toolbar other than the navigation toolbar

Categories

(Firefox :: Theme, defect, P3)

40 Branch
Unspecified
Windows
defect

Tracking

()

VERIFIED FIXED
Firefox 43
Tracking Status
firefox40 --- wontfix
firefox41 + verified
firefox42 + verified
firefox43 + verified

People

(Reporter: potapovsanya, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(4 files)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812163655

Steps to reproduce:

I want the buttons in toolbars to be small. But zoom buttons stay big (see attached screenshot). This problem has cropped up after updating to 40.0.2.
UPD: The problem shows up only when placing zoom buttons in the menubar. When placing them in the toolbar, they do change size.
Theme issue maybe.

Could you test:
1) in safe mode:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
2) with a fresh profile:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Component: Untriaged → Toolbars and Customization
Flags: needinfo?(potapovsanya)
Attached image ff-buttons.png
Flags: needinfo?(potapovsanya)
>Theme issue maybe.

It preserves with different themes. I suspect it is related to the "Classic Theme Restorer" add-on. I even forgot I was using it. In safe mode there is not even an option to choose small or normal buttons (see the 2nd attached image). So perhaps I should report this to the add-on author.
So try with a fresh profile without addon, it's easy to know if the culprit is Classic Theme Restorer.
Component: Toolbars and Customization → Theme
Attached image ff-clean-profile.png
When using a clean profile the zoom controls and the "downloads" button, for example, do have different size (see "ff-clean-profile.png" file). Don't know if it qualify as a bug, though IMO all buttons should have the same size.
This issue is not related to Classic Theme Restorer add-on.

- create a clean profile (do not install any add-ons)
- make menubar and bookmarks toolbar visible
- move zoom controls or copy/cut/paste controls to any toolbar but navigation toolbar

This issue is only visible on hidpi modes, so make sure you have set Windows dpi settings to 125% or higher to reproduce this.

http://i.imgur.com/IE5edrJ.png
Regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8f57f60ee58a&tochange=fec90cbfbaad
Blocks: 1147702
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(dao)
Keywords: regression
OS: Unspecified → Windows
Summary: In FF 40.0.2 the small versions of zoom buttons for toolbar seem to be missing → In FF 40.0.2 the small versions of zoom buttons and copy/cut/paste controls for any toolbar except navigation toolbar are missing on HiDPI devices
Tracked as it's a recent regression.
Assignee: nobody → dao
Flags: needinfo?(dao)
Summary: In FF 40.0.2 the small versions of zoom buttons and copy/cut/paste controls for any toolbar except navigation toolbar are missing on HiDPI devices → [HiDPI] Nested toolbar buttons (zoom in, zoom out, copy, cut, paste) are oversized when moved to a toolbar other than the navigation toolbar
Blocks: 1192839
Priority: -- → P2
Priority: P2 → P3
This was reported earlier in bug 1155874, but I failed to recognize that it's HiDPI issue
See Also: → 1155874
See Also: 1155874
Duplicate of this bug: 1155874
While this is a valid issue, I don't think this is a release blocker. We will have to wontfix this for 41.
No longer blocks: 1192839
Attached patch patchSplinter Review
Attachment #8657434 - Flags: review?(jaws)
Comment on attachment 8657434 [details] [diff] [review]
patch

Review of attachment 8657434 [details] [diff] [review]:
-----------------------------------------------------------------

Nice find.
Attachment #8657434 - Flags: review?(jaws) → review+
Actually I think we should still try to uplift this to beta...
Flags: qe-verify+
Comment on attachment 8657434 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: bug 1147702
[User impact if declined]: oversized zoom, cut, copy and paste buttons when moving them to a toolbar other than the navigation toolbar with high DPI
[Describe test coverage new/current, TreeHerder]:
[Risks and why]: no new code, just fixing broken CSS selectors, low risk
[String/UUID change made/needed]:
Attachment #8657434 - Flags: approval-mozilla-beta?
Attachment #8657434 - Flags: approval-mozilla-aurora?
Comment on attachment 8657434 [details] [diff] [review]
patch

The patch looks simple enough, let's uplift to Beta41 and Aurora42.
Attachment #8657434 - Flags: approval-mozilla-beta?
Attachment #8657434 - Flags: approval-mozilla-beta+
Attachment #8657434 - Flags: approval-mozilla-aurora?
Attachment #8657434 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/3cb1b3b2a6ec
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
I was able to reproduce this issue on Firefox 43.0a1 (2015-09-06) using Windows 7 64-bit.

Verified fixed on Firefox 43.0a1 (2015-09-08), Firefox 42.0a2 (2015-09-08) and Firefox 41 Beta 8(20150907144446) under Windows 7 64-bit with 125% dpi.
You need to log in before you can comment on or make changes to this bug.