Closed Bug 1194778 Opened 5 years ago Closed 5 years ago

Loading Flash/Flex application results in Error #2032 in Firefox 40.x and Flash 18.x

Categories

(Core :: Plug-ins, defect)

40 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1194600

People

(Reporter: richard.arcega, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.66 Safari/537.36

Steps to reproduce:

When loading a flash/flex application swf in Firefox 40.x and Flash 10.x, Error #2032 will be returned sporadically. 

1. Navigate to https://trade.tdameritrade.com
2. Wait until the page is loaded
3. Sporadically the application will fail to load, citing Error #2032. Please see the attached screenshot.


Actual results:

Sporadically the application will fail to load, Error #2032 is returned. Please see the attached screenshot.


Expected results:

The application/swf loads successfully.
I think it's a dupe of bug 1193393 which is already fixed in Firefox 42+. Could you download Aurora (42) or Nightly (43) and confirm the application doesn't fail to load.

Aurora:  https://www.mozilla.org/en-US/firefox/developer/all/
Nightly: https://nightly.mozilla.org/
Component: Untriaged → Plug-ins
Flags: needinfo?(richard.arcega)
Product: Firefox → Core
Forget my previous message. It's probably due to Asynchronous Plugin Initialization enabled by default in FF40.

But I'm not able to reproduce it with the URL https://trade.tdameritrade.com/ even if I reload the page 10x.
On your screenshot, I see the URL is different (probably this one of your dev server), maybe it's reproducible only in this environment.

Could you provide a different URL testcase?
Yes, the url used in the screenshot is a testing environment. However, we are also experiencing this issue in the  production url  https://trade.tdameritrade.com.
Flags: needinfo?(richard.arcega)
I reproduced only once. Could you set about:config>dom.ipc.plugins.asyncInit=false (restart FF) and test on your side to know if it's reproducible?
Blocks: asyncplugininit-compat
No longer blocks: asyncplugininit
This is no longer reproducible after setting the config preference dom.ipc.plugins.asyncInit to false.
Please try to verify on the next beta 41 release.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1194600
Reproduced with Firefox 41 beta 2 build.
The issue no longer occurs with Firefox 41 beta 5 under Win 7 64-bit and Mac OS X 10.9.5.
You need to log in before you can comment on or make changes to this bug.