Closed Bug 1194884 Opened 4 years ago Closed 4 years ago

WebM playback only decodes half of the frames

Categories

(Core :: Audio/Video: Playback, defect)

42 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox41 --- unaffected
firefox42 + fixed
firefox43 + fixed

People

(Reporter: antonio_mario_novo, Assigned: jya)

References

Details

(Keywords: regression)

Attachments

(4 files)

User Agent: Mozilla/5.0 (masking-agent; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150813030208

Steps to reproduce:

Open and play a WebM file and its equivalent MP4 (container), examnple:
http://techslides.com/demos/sample-videos/small.webm
and
http://techslides.com/demos/sample-videos/small.mp4


Actual results:

While the MP4 file plays-back as it should, the WebM lacks _exactly_ half of its frames (not decoded nor painted).
Play-back is still done correctly, no sound or temporal problems arise, but the apparent lack of decent frame rate can be seen.


Expected results:

Playback of WebM files should decode all frames needed to play-back the file the best it can (on the target machine).



Contrary to bug 571386, where frames are dropped somewhat randomly (maybe according to load?) exactly half of the frames on the video file are not decoded.

Also, according to layers.acceleration.draw-fps, both tabs/layers lock in at 75FPS while playing both files (75Hz screen refresh rate). CPU load remains the same in both cases.
[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

I can see the dropping frams in "Show Statics". 
https://hg.mozilla.org/mozilla-central/rev/4e883591bb5dff021c108d3e30198a99547eed1e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0 ID:20150814030208


Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=bdb808a2dd66&tochange=195776f0148b

Regressed by: Bug 1185792
Blocks: 1185792
Status: UNCONFIRMED → NEW
Component: General → Audio/Video: Playback
Ever confirmed: true
Keywords: regression
Version: 43 Branch → 42 Branch
Jan, can you have a look?  seems to be what's causing bug 762774
Flags: needinfo?(j)
Assignee: nobody → jyavenard
Remove duplicated code.
Also some fixes with log types.
Attachment #8648395 - Flags: review?(j)
turned out to be an easy one...
Flags: needinfo?(j)
Depends on: 1190238
Attachment #8648395 - Flags: review?(j) → review+
Attachment #8648397 - Flags: review?(j) → review+
https://hg.mozilla.org/mozilla-central/rev/e8ce7726fa5a
https://hg.mozilla.org/mozilla-central/rev/959cc9cb112f
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Tracking since this is a regression. 
Jean-Yves, want to nominate this for uplift?
Flags: needinfo?(jyavenard)
Yes.

I have a long list to uplift for aurora and beta.
Flags: needinfo?(jyavenard)
Comment on attachment 8648397 [details] [diff] [review]
[webm] P2. Retrieve all VPX decoded frames from decoder. r=j^

Approval Request Comment
[Feature/regressing bug #]: 1185792
[User impact if declined]: webm videos will play with 50% dropped frames
[Describe test coverage new/current, TreeHerder]: in central, local test. confirmed issue fixed by users.
[Risks and why]: Very low, this is now using the same logic as the previous WebMReader VPx decoder.
[String/UUID change made/needed]: None
Attachment #8648397 - Flags: approval-mozilla-aurora?
Attachment #8648397 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Blocks: 1197083
No longer blocks: 1197083
You need to log in before you can comment on or make changes to this bug.