If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Camera]It will return to the camera or preview when you tap the share twice very quickly and share photo to the email.

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::Camera
P3
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Queena.Wen(Leave from Mozilla), Assigned: aosmond)

Tracking

({regression})

unspecified
FxOS-S8 (02Oct)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-aries-test-run-1])

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
[1.Description]:
[Flame v2.5][Aries KK v2.5] In the preview, tap the share icon twice very quickly, then share the photo to the email,it will return to the camera or preview.
Found Time:04:01
See attachment: Flame_v2.5.3gp and  logcat_0401.txt

[2.Testing Steps]: 
The precondition: sign in the email account.
1.Launch the camera
2.Take a photo
3.Click the preview circle
4.Click the share icon quickly for twice
5.Share the photo to email

[3.Expected Result]: 
5.It should stay in compose email view.

[4.Actual Result]: 
5.It displays the compose email view 1 or 2 seconds, then it returns to the camera or preview.

[5.Reproduction build]: 
Device: Aries KK 2.5(Affected)
Build ID               20150818004549
Gaia Revision          60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gaia Date              2015-08-16 02:21:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b41e31b71828f9b6f59394945c172f0f57826072
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150818.000838
Firmware Date          Tue Aug 18 00:08:48 UTC 2015
Bootloader             s1

Device: Flame KK 2.2(Unaffected)
Build ID               20150818032504
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c29970d16372
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150818.065127
Firmware Date          Tue Aug 18 06:51:38 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5(Affected)
Build ID               20150818150207
Gaia Revision          507ba38fb64b27f87d11f4104dfcc58448e12b1a
Gaia Date              2015-08-18 10:50:12
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2c272af993c23e803f6ea7798a812b0c8abfad4d
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150818.184156
Firmware Date          Tue Aug 18 18:42:07 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
occasionally Recurrence,2/10

[7.TCID]: 
Free Test

[8.Note]:
In the step 5, in  Aries v2.5 , the  preview circle will disappear.
(Reporter)

Updated

2 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Keywords: regression
(Reporter)

Comment 1

2 years ago
Created attachment 8649809 [details]
logcat_0401.txt
(Reporter)

Comment 2

2 years ago
Created attachment 8649810 [details]
Flame_v2.5.3gp

Comment 3

2 years ago
Interesting. I can use foxfood device(Build ID:20150619.224059) to reproduce it.
I found another symptom. UI hangs there and then camera app sometimes automatically closed.
- https://www.youtube.com/watch?v=uWG9wVvPCTE
It shall not be a blocker. But, request to fix this issue because the user experience isn't good.
(Reporter)

Comment 4

2 years ago
"UI hangs there and then camera app sometimes automatically closed." Sometimes this phenomenon appeared.
ni?ing aosmond for input, in case it's not a camera app issue
Flags: needinfo?(aosmond)

Updated

2 years ago
Priority: -- → P3
(Assignee)

Comment 6

2 years ago
Bug 1182557 added the busy spinner which makes this harder to reproduce but still possible (at least the STR/problems in comment 3 and 4). Culprit seems to be multiple share activities are triggered, resulting in multiple image resizes.
Assignee: nobody → aosmond
Status: NEW → ASSIGNED
Flags: needinfo?(aosmond)
See Also: → bug 1182557

Comment 7

2 years ago
Created attachment 8665212 [details] [review]
[gaia] aosmond:bug1196195 > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Attachment #8665212 - Flags: review?(jdarcangelo)
Attachment #8665212 - Flags: review?(jdarcangelo) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/fb37000ca2302f0d5a130bacaeff3e796b8eb7cb
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S8 (02Oct)
(Reporter)

Comment 9

2 years ago
This bug has been verified as "pass" on the latest build of Flame KK v2.5&Aries KK v2.5 by the STR in comment 0.

Actual results: It stays in compose email view. 

See attachment: Verified_Aries_KK_v2.5.3gp
Reproduce rate: 0/10

Device: Aries KK v2.5(Pass)
Build ID               20150925003138
Gaia Revision          4bb17b24620818cbda0ba0c0d69e0ce3f914e1b7
Gaia Date              2015-09-23 16:06:39
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/eee4266046984718e4daa99d94ce820f3fd86d32
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150925.001452
Firmware Date          Fri Sep 25 00:15:01 UTC 2015
Bootloader             s1

Device: Flame KK v2.5(Pass)
Build ID               20150924150202
Gaia Revision          4bb17b24620818cbda0ba0c0d69e0ce3f914e1b7
Gaia Date              2015-09-23 16:06:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/001942e4617b2324bfa6cdfb1155581cbc3f0cc4
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150924.183612
Firmware Date          Thu Sep 24 18:36:29 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
(Reporter)

Updated

2 years ago
status-b2g-master: affected → verified
(Reporter)

Updated

2 years ago
QA Whiteboard: [MGSEI-Triage+]
(Reporter)

Comment 10

2 years ago
Created attachment 8665841 [details]
Verified_Aries_KK_v2.5.3gp
You need to log in before you can comment on or make changes to this bug.