[Aries][Camera] After sharing a picture from Camera Preview, image will be rotated/stretched in preview

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::Camera
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: oliverthor, Assigned: aosmond)

Tracking

(Blocks: 1 bug, {regression})

unspecified
FxOS-S5 (21Aug)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing], [Spark], URL)

Attachments

(2 attachments, 4 obsolete attachments)

(Reporter)

Description

3 years ago
Description:
When an Aries devices uses the camera to take a picture and then share said picture from the camera's previewed images, they will observe that the image will become rotated in the preview images thereafter. This rotation is limited to the Camera Preview, and does not affect how the image is saved to the phone's own gallery, or for any sharing of the image while it maintains this distortion. This only affects pictures take in portrait view, they will become
Confirmed occurring after sharing via Messages, or wallpaper.

Repro Steps:
1) Update a Aries to 20150710105517
2) Open the Camera app
3) Take a picture
4) Tap preview image
5) Share picture to Wallpaper, set.
6) After picture is sent, return to camera preview image and observe same picture

Actual:
Picture is shown rotated in preview image; does not affect how actual image is saved or shared.

Expected:
Picture is shown in preview image identical to the state it had before performing share activities


Environmental Variables:
-------------------------

Device: Aries 2.5
Build ID: 20150710105517
Gaia: ad76c159c641c977d9140c5fedea84aea04e0e60
Gecko: f7e1f596d57d
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
****************

Issue DOES NOT REPRODUCE on master for flame devices
Results: Picture is shown in preview image identical to the state it had before performing share activities

Device: Flame 2.5
BuildID: 20150710010203
Gaia: ad76c159c641c977d9140c5fedea84aea04e0e60
Gecko: 2c91d57441fd
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
-------------------------


Repro frequency: 5/5
See attached: 
video- https://youtu.be/pyg2fhbypjI
logcat
(Reporter)

Comment 1

3 years ago
Created attachment 8632179 [details]
logcat_20150710_1032.txt
(Reporter)

Comment 2

3 years ago
This appears as a device regression from Aries to Flame; does not reproduce on flame devices.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
(Reporter)

Updated

3 years ago
Blocks: 1171119
[Blocking Requested - why for this release]:
graphical regression.

Requesting a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
This issue is a device specific issue not a regression.
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Flags: needinfo?(ktucker)
David, didn't we have a similar bug like this?
Flags: needinfo?(dflanagan)

Updated

3 years ago
blocking-b2g: 2.5? → 2.5+
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #5)
> David, didn't we have a similar bug like this?

No, I don't remember seeing anything like this before.

The reason that this affects Aries and not Flame is that the Aries camera does not rotate the images it takes and just sets an EXIF orientation flag. So if you take a portrait mode photo on Aries, the camera app has to manually rotate that image to display it correctly.

When we share an image like this, we manually rotate it before sharing so that the app that receives it does not need to be EXIF-aware.

I suppose there could be two things going on here:

1) when the image is shared we are replacing the original with the rotated version but aren't changing the flag that says it needs to be manually rotated, so we're ending up rotating the already-rotated image.

2) we are somehow clearing the rotation flag during the share so that when we come back to the preview we are not rotating an image that does need to be rotated.

It should be possible to figure out which of these is happening by looking at which way the image is coming out, though that may be harder than it sounds.

I'd guess that Justin is the one that knows this part of the Camera app the best, so setting needinfo for him.
Flags: needinfo?(dflanagan) → needinfo?(jdarcangelo)

Updated

3 years ago
See Also: → bug 1161925
(Assignee)

Updated

3 years ago
Flags: needinfo?(jdarcangelo) → needinfo?(aosmond)
(Assignee)

Updated

3 years ago
Assignee: nobody → aosmond
Status: NEW → ASSIGNED
Created attachment 8647600 [details] [review]
[gaia] aosmond:bug1182557 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Flags: needinfo?(aosmond)
Attachment #8647600 - Flags: review?(jdarcangelo)
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1194629
Comment on attachment 8647600 [details] [review]
[gaia] aosmond:bug1182557 > mozilla-b2g:master

LGTM.
Attachment #8647600 - Flags: review?(jdarcangelo) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/47c91ffe7f500ca1aaa60de0aabf4d2429120733
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S5 (21Aug)
(Reporter)

Comment 11

2 years ago
Created attachment 8648987 [details]
logcat_20150817_1523.txt

This issue is still occurring in aries devices on master
Results: Image preview appears rotated after attempting to share an image

Device: Aries Master
BuildID: 20150817141354
Gaia: 60489c1ff8c5d1633fc4837d4f8019623d4e1940
Gecko: a6eeb28458fd2652e12e57334f046b7776d75bb4
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (Master) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro: 5/5
Video: https://youtu.be/g2TJsjqRzhY
(Reporter)

Updated

2 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

2 years ago
(In reply to Oliver Nelson [:oliverthor] from comment #11)
> Created attachment 8648987 [details]
> logcat_20150817_1523.txt
> 
> This issue is still occurring in aries devices on master
> Results: Image preview appears rotated after attempting to share an image
> 
> Device: Aries Master
> BuildID: 20150817141354
> Gaia: 60489c1ff8c5d1633fc4837d4f8019623d4e1940
> Gecko: a6eeb28458fd2652e12e57334f046b7776d75bb4
> Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
> Version: 43.0a1 (Master) 
> Firmware Version: D5803_23.1.A.1.28_NCB.ftf
> User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
> 
> Repro: 5/5
> Video: https://youtu.be/g2TJsjqRzhY

Thanks, I'll take a look; the original STR doesn't reproduce for me anymore, but following your steps in the video does.
(Reporter)

Comment 13

2 years ago
Created attachment 8648990 [details]
logcat_cannot_gesture_away_from_rotated_images.txt

I believe this created a new regression as well, where the user may no longer gesture away from a preview image that has been impacted by this rotation change:

* https://youtu.be/DVC6qnB4h9Q

Results: Once an image has been affected by this rotational bug, it may no longer be gestured away from in image previews. No workaround, closing the app clears the camera preview 'cache' and removes all images.
Created attachment 8649059 [details] [review]
[gaia] aosmond:bug1182557_v2 > mozilla-b2g:master
(Assignee)

Comment 15

2 years ago
Comment on attachment 8649059 [details] [review]
[gaia] aosmond:bug1182557_v2 > mozilla-b2g:master

Attempt #2...
Attachment #8649059 - Flags: review?(jdarcangelo)
Comment on attachment 8649059 [details] [review]
[gaia] aosmond:bug1182557_v2 > mozilla-b2g:master

After discussing on IRC, this looks good. One nit in the PR.
Attachment #8649059 - Flags: review?(jdarcangelo) → review+
(Assignee)

Updated

2 years ago
Attachment #8632179 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Attachment #8647600 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Attachment #8648987 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Attachment #8648990 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/4c6c773d38663bf68a1e599332688cedfb0b54f7
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED

Comment 18

2 years ago
Created attachment 8651585 [details]
Verified_ Aries_kk2.5.3gp

This bug has been verified as "Pass" on latest build of  Aries KK  v2.5 by the STR in Comment 0.
Actual results: Picture is shown in preview image identical to the state it had before performing share activities.
See attachment: Verified_ Aries_kk2.5.3gp
Reproduce rate: 0/5

Device: Aries KK 2.5(Pass)
Build ID               20150823221817
Gaia Revision          cddb9f610cbe03d0ca39d81bbdce46a0fca841ab
Gaia Date              2015-08-23 03:34:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4ccdd06e51d7209ba429196df7cab97bf66962db
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150823.214038
Firmware Date          Sun Aug 23 21:40:46 UTC 2015
Bootloader             s1

Updated

2 years ago
status-b2g-master: fixed → verified

Updated

2 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
(Assignee)

Updated

2 years ago
See Also: → bug 1196195
You need to log in before you can comment on or make changes to this bug.