Closed Bug 1196530 Opened 5 years ago Closed 4 years ago

/whatsnew Developer Edition 44 - URL

Categories

(Release Engineering :: Release Requests, defect)

defect
Not set

Tracking

(firefox44 verified)

VERIFIED FIXED
Tracking Status
firefox44 --- verified

People

(Reporter: ckprice, Assigned: jlund)

References

Details

(Whiteboard: [fall-2015-engagement])

Attachments

(1 file, 1 obsolete file)

This bug is to execute the /whatsnew URL for Firefox 42.
Blocks: 1196183
Assignee: nobody → rail
It will be added automatically by https://hg.mozilla.org/build/buildbot-configs/rev/d7c1ca472072#l1.13
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1218444
Trying to QA the URL on Beta 42 using this method

> To simulate an upgrade to test whatsnew,
> decrease the version number in the 
> browser.startup.homepage_override.mstone preference

But I'm unable to see the whatsnew URL. Is there another method to test this?
Flags: needinfo?(rail)
Summary: /whatsnew 42 - URL → /whatsnew RC42 & DE44 - URL
You need to be on the release-localtest channel to get updates to 42.0build1. It's the update server telling you what page should be opened.

You can change the channel by editing "defaults/pref/channel-prefs.js" in your app directory (not your profile) and restart firefox.

Let me know how it worked.
Flags: needinfo?(rail)
Oh, I just saw "dev 44" in the title... Hmm, this is not as easy as it sounds and requires in-product changes. Let me find a similar bug...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: /whatsnew RC42 & DE44 - URL → /whatsnew DE44 - URL
(In reply to Rail Aliiev [:rail] from comment #5)
> Oh, I just saw "dev 44" in the title... Hmm, this is not as easy as it
> sounds and requires in-product changes. Let me find a similar bug...

Yeah - I tried to open bug 1218444, but it was marked a dup. Assumed both were going to be done in one.

Will give the channel-prefs thing a try.
Summary: /whatsnew DE44 - URL → /whatsnew Developer Edition 44 - URL
See Also: → 1170567
Gijs, I think the request is that we open a whatsnew page the first time a user updates to Dev Ed 44, but not for any updates afterwards. Please correct that Cory if needed.

IIRC the code is in
 https://dxr.mozilla.org/mozilla-central/source/browser/components/nsBrowserContentHandler.js
The mstone should be changing to 44.0a2, so we should go down the OVERRIDE_NEW_MSTONE code path and open a page at startup.homepage_override_url. Currently that's not set at
  https://dxr.mozilla.org/mozilla-central/source/browser/branding/aurora/pref/firefox-branding.js#7
but we could land a change before the merge (or at least one nightly before we want to turn Dev Ed updates back on).

An example update query is
 https://aus4.mozilla.org/update/3/Firefox/39.0a1/20150320030211/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/aurora/Darwin%2014.1.0/default/default/update.xml
and we're not setting any 'action' in there to override the in-app prefs.
Flags: needinfo?(gijskruitbosch+bugs)
From IRC:

> Gijs: if we set that pref to the whatsnew page, will the it be shown only the first time a user updates to 44 dev Ed 

Yes, although of course, if you leave it set like that it will also do that for the 45 upgrade, etc...
Flags: needinfo?(gijskruitbosch+bugs)
Assignee: rail → jlund
<poking stick>

nick: we uplifted early this morning and a nightly has already been triggered for 44: Firefox-mozilla-aurora-nightly-20151029045227

However, that is not being served as we have locked updates so I think we are still okay to go the suggested route in comment 7

now, what to put here is the next question..

I was a bit confused about which url base we want for this. sometimes we use https://www.mozilla.org/projects/firefox/%VERSION% and other times we use https://www.mozilla.org/%LOCALE%/firefox/%VERSION%


the last time the override url was populated we had the following: https://hg.mozilla.org/releases/mozilla-aurora/diff/f7f2daa08d79/browser/branding/aurora/pref/firefox-branding.js#l1.6

currently, m-c nightly agrees with this url base style: https://dxr.mozilla.org/mozilla-central/rev/1e700005a0ddf2b17803213e1f3f8d78a7a618b8/browser/branding/nightly/pref/firefox-branding.js#5

however, current aurora homepage_welcome_url[1] suggests to use: `https://www.mozilla.org/%LOCALE%/firefox/%VERSION%/` so I am going with that.

The second confusion is whether or not we need ?oldversion=%OLD_VERSION% param. 
Looking at where homepage_override_url is used[2], we would only reference it when we are coming from an oldversion (older gecko version, OVERRIDE_NEW_MSTONE) anyway so so I don't *think* we need oldversion= param specified.

finally, there are other parts of gecko that use this homepage_override_url[3] so i'm hoping that's expected and they do the right thing.

</poking stick>

[1] https://hg.mozilla.org/releases/mozilla-aurora/file/8ccfd518beef/browser/branding/aurora/pref/firefox-branding.js#l8
[2] https://dxr.mozilla.org/mozilla-central/source/browser/components/nsBrowserContentHandler.js#536
[3] https://dxr.mozilla.org/mozilla-central/search?q=homepage_override_url&=mozilla-central&redirect=true
Attachment #8680868 - Flags: review?(nthomas)
Comment on attachment 8680868 [details] [diff] [review]
151029_1196530_whatsnew_dev44-m-a.patch

Review of attachment 8680868 [details] [diff] [review]:
-----------------------------------------------------------------

The questions about the url and oldversion query parameter are best directed at ckprice or pmac, as it depends how they are implementing things on the www.mozilla.org side. I think you're on the right track so I'll f+, but once the details are settled please ask for review from a peer of the Firefox module.
Attachment #8680868 - Flags: review?(nthomas) → feedback+
FTR, the patch above should be landed before we start generating nightly builds on Tue, ideally today.


Blockers:
 * WNP URL
 * Firefox peer review of the patch
Hi

(In reply to Jordan Lund (:jlund) from comment #9)
> however, current aurora homepage_welcome_url[1] suggests to use:
> `https://www.mozilla.org/%LOCALE%/firefox/%VERSION%/` so I am going with
> that.

That's the one, except with `whatsnew` at the end.

Here's the whastnew and firstrun pages on our demo servers ready to go

https://www-demo4.allizom.org/en-US/firefox/44.0a2/whatsnew/
https://www-demo4.allizom.org/en-US/firefox/44.0a2/firstrun/

NI jlund: Can you please confirm that this is will be the %VERSION% value? We are expecting the `a` value in the URL.

> 
> The second confusion is whether or not we need ?oldversion=%OLD_VERSION%
> param. 
> Looking at where homepage_override_url is used[2], we would only reference
> it when we are coming from an oldversion (older gecko version,
> OVERRIDE_NEW_MSTONE) anyway so so I don't *think* we need oldversion= param
> specified.

The `oldversion` value is useful to get an idea of metrics on this page, but not a requirement.

Thanks!
Flags: needinfo?(jlund)
> > however, current aurora homepage_welcome_url[1] suggests to use:
> > `https://www.mozilla.org/%LOCALE%/firefox/%VERSION%/` so I am going with
> > that.
> 
> That's the one, except with `whatsnew` at the end.
> 

cool, I'll stick with the `https://www.mozilla.org/%LOCALE%/firefox/%VERSION%/` url base.

> 
> NI jlund: Can you please confirm that this is will be the %VERSION% value?
> We are expecting the `a` value in the URL.

the VERSION should expand to 44.0a2


> The `oldversion` value is useful to get an idea of metrics on this page, but
> not a requirement.

okay, I'll keep oldversion in the url


patch incoming to reflect oldversion addition.
Flags: needinfo?(jlund)
Hey Cory,

So I'm going to forward along nick's f+ which covers the code logic and ask you for the final r? to sign off on the actual url.

This url should be in line with the demo url whatsnew example you gave me.

Essentially, `https://www.mozilla.org/%LOCALE%/firefox/%VERSION%/whatsnew/?oldversion=%OLD_VERSION%` will show up the first time a user updates to 44 and that time only thanks to https://dxr.mozilla.org/mozilla-central/source/browser/components/nsBrowserContentHandler.js#526 AIUI

I will land directly on aurora and kick off a nightly immediately. Then let you know once the nightly is done and I have updated the auroratest channel for you to manually verify things are working as you expect.

sound good?
Attachment #8680868 - Attachment is obsolete: true
Attachment #8681388 - Flags: review?(cprice)
Attachment #8681388 - Flags: feedback+
Comment on attachment 8681388 [details] [diff] [review]
151030_1196530_whatsnew_dev44-m-a.patch

Review of attachment 8681388 [details] [diff] [review]:
-----------------------------------------------------------------

>"https://www.mozilla.org/%LOCALE%/firefox/%VERSION%/whatsnew/?oldversion=%OLD_VERSION%");

URL looks good.

Works with the demo mask[0], given your confirmation that the final version value will be 44.0a2

Thanks!

[0] https://www-demo4.allizom.org/en-US/firefox/44.0a2/whatsnew/?oldversion=40.0a2
Attachment #8681388 - Flags: review?(cprice) → review+
Comment on attachment 8681388 [details] [diff] [review]
151030_1196530_whatsnew_dev44-m-a.patch

Approval Request Comment
[Feature/regressing bug #]: this one
[User impact if declined]: no whatsnew page for dev edition users upgrading to 44
[Describe test coverage new/current, TreeHerder]:
[Risks and why]: 
[String/UUID change made/needed]:
Attachment #8681388 - Flags: approval-mozilla-aurora?
Comment on attachment 8681388 [details] [diff] [review]
151030_1196530_whatsnew_dev44-m-a.patch

Review of attachment 8681388 [details] [diff] [review]:
-----------------------------------------------------------------

needed for 44, taking it.
Attachment #8681388 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8681388 [details] [diff] [review]
151030_1196530_whatsnew_dev44-m-a.patch

thanks and thanks

https://hg.mozilla.org/releases/mozilla-aurora/rev/d0b283bc162b
Attachment #8681388 - Flags: checked-in+
I was able to verify this on OSX with jlund.
(In reply to Jordan Lund (:jlund) from comment #18)
> Comment on attachment 8681388 [details] [diff] [review]
> 151030_1196530_whatsnew_dev44-m-a.patch
> 
> thanks and thanks
> 
> https://hg.mozilla.org/releases/mozilla-aurora/rev/d0b283bc162b

adjusting the flag
Running the steps from Comment 3 are displayed the following pages in Firefox 44 Developer Edition:

Firefox 44.0a2 First run page: http://i.imgur.com/8ScwtH4.jpg
Firefox 44.0a2 WhatsNew page: http://i.imgur.com/l8uKvQS.jpg


This pages do not correspond to whastnew and firstrun mockups from Comment 12:
First run https://www-demo4.allizom.org/en-US/firefox/44.0a2/firstrun/
WhatsNew https://www-demo4.allizom.org/en-US/firefox/44.0a2/whatsnew/


Is this an issue? Because I’ve also tested using the overwrite update method and the results are the same.


Tested on Firefox 44.0a2 (2015-11-01/02) under Windows 7 64-bit, Ubuntu 14.04 32-bit and Mac Os X 10.10.4.
Flags: needinfo?(cprice)
(In reply to Vasilica Mihasca, QA [:vasilica_mihasca] from comment #21)
> Running the steps from Comment 3 are displayed the following pages in
> Firefox 44 Developer Edition:
> 
> Firefox 44.0a2 First run page: http://i.imgur.com/8ScwtH4.jpg
> Firefox 44.0a2 WhatsNew page: http://i.imgur.com/l8uKvQS.jpg
> 
> 
> This pages do not correspond to whastnew and firstrun mockups from Comment
> 12:
> First run https://www-demo4.allizom.org/en-US/firefox/44.0a2/firstrun/
> WhatsNew https://www-demo4.allizom.org/en-US/firefox/44.0a2/whatsnew/
> 
> 
> Is this an issue? Because I’ve also tested using the overwrite update method
> and the results are the same.
> 
> 
> Tested on Firefox 44.0a2 (2015-11-01/02) under Windows 7 64-bit, Ubuntu
> 14.04 32-bit and Mac Os X 10.10.4.

Thanks for the note.

The production content will not be live until tomorrow AM PST when the feature is available. That's when the content on the demo server will be pushed to production.

Your screencaptures note that the URL is correctly showing version `44.0a2` which will trigger our pages to show the new content.

This is all working as expected.

Thanks!
Flags: needinfo?(cprice)
Based on Comment 21 and Comment 22, I am marking this bug as Verified for Firefox 44.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Blocks: 1221205
Status: RESOLVED → VERIFIED
Depends on: 1221493
(In reply to Cory Price [:ckprice] from comment #3)
> > To simulate an upgrade to test whatsnew,
> > decrease the version number in the 
> > browser.startup.homepage_override.mstone preference
I don't understand why this method works on FF 44, but doesn't work on 42, 43, 45.
Flags: needinfo?(jlund)
(In reply to Rail Aliiev [:rail], on PTO Nov 21 - Mozlandia from comment #4)
> You need to be on the release-localtest channel to get updates to
> 42.0build1. It's the update server telling you what page should be opened.
Moreover, what channel should be used to update from 42beta to 43beta in order to see the Whatsnew page? Doesn't seem to work with "beta-localtest".
(In reply to Paul Silaghi, QA [:pauly] from comment #24)
> (In reply to Cory Price [:ckprice] from comment #3)
> > > To simulate an upgrade to test whatsnew,
> > > decrease the version number in the 
> > > browser.startup.homepage_override.mstone preference
> I don't understand why this method works on FF 44, but doesn't work on 42,
> 43, 45.

(In reply to Paul Silaghi, QA [:pauly] from comment #25)
> (In reply to Rail Aliiev [:rail], on PTO Nov 21 - Mozlandia from comment #4)
> > You need to be on the release-localtest channel to get updates to
> > 42.0build1. It's the update server telling you what page should be opened.
> Moreover, what channel should be used to update from 42beta to 43beta in
> order to see the Whatsnew page? Doesn't seem to work with "beta-localtest".

Beta is different. AFAIK, we don't have a whatsnew page on the beta channel. This bug deals specifically with aurora and aurora/dev itself differs from release whatsnew too IIUC
Flags: needinfo?(jlund)
You need to log in before you can comment on or make changes to this bug.