Closed Bug 1196602 Opened 7 years ago Closed 6 years ago

Requesting a loaner machine b2g_ubuntu64_vm to diagnose Bug 1194979

Categories

(Infrastructure & Operations Graveyard :: CIDuty, task)

x86_64
All
task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gweng, Assigned: aselagea)

Details

(Whiteboard: [buildduty][loaner])

Hello, I need a loaner machine of type b2g_ubuntu64_vm since I want to diagnose why some Gaia Unit tests only failed on CI environment. The failure is recorded at Bug 1194979.
No longer blocks: 1043892
No longer depends on: 1053688
Email sent to :gweng for further instructions. 

Loaning machines: 
- tst-linux64-ec2-gweng

Hi Greg, 

I am going to assign this to you to keep track of the loan. 

When you are finished with the loan forever, please comment stating so here in the bug, and mark the bug as RESOLVED.

By the way, now that this aws instance has been created, starting and stopping it can happen in a flash!
If you are not going to be using this machine for multiple hours, let us know in this bug and we can stop it.

Comment again when you want it started back up.
* For faster turnaround, ping #releng (look for nick with 'buildduty')
Assignee: nobody → gweng
Hi Alin: when I tried to connect to the machine with the FQDN under VPN protection, it reported

    port 22: Connection refused

Does this mean I need to do some other configs to connect to the instance?
Flags: needinfo?(alin.selagea)
Hello Greg,

Sorry for the inconvenience. I only added the IP and hostname of the machine in VPN ACL, but not your account. It should be fixed now, so please try again.
Flags: needinfo?(alin.selagea)
It shows the same error. I write my steps to make sure I didn't do anything wrong:

1. Use Tunnelblick with the config file extracted from the package downloaded from the logins server
2. Connect to datacenter VPN with my own account and password. I confirmed that since only when it shows 'connected' the DNS can solve the instance to IP, otherwise it is unable to find the server
3. Try to ssh the instance with the account and password in your mail. The server seems connected but it still refuse the connection as I post at Comment 2.
Flags: needinfo?(alin.selagea)
Before going further, please disconnect from the VPN, reconnect to it and then try to ssh once more.
Thanks.
Flags: needinfo?(alin.selagea)
Just an update: I now use it to debug another serious intermittent error, which relates to Bug 1194979,
gweng, do you still need this loaner ?
Flags: needinfo?(gweng)
Oh no, I don't need it anymore. Because I have been unable to connect to it after there is no need to debug that, I thought the VM has been released and forgot this bug. Thanks.
Flags: needinfo?(gweng)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Actually, there's no dependent bug to handle the cleanup, so lets reopen this for SoftVision to handle.
Assignee: gweng → nobody
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assigning to Alin to silence the nagios alert about loaner bugs.
Assignee: nobody → alin.selagea
Terminated the instance, removed inventory entries and revoked VPN access.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Component: Loan Requests → Buildduty
Product: Release Engineering → Infrastructure & Operations
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.