[Contacts] After editing a contact the status bar will turn white

RESOLVED DUPLICATE of bug 1196893

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 1196893
2 years ago
2 years ago

People

(Reporter: AdamA, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8650721 [details]
logcat

Description:
After a user edits a preexisting contact and changes some portion of the contact the status bar will turn white after confirming the edits.

Repro Steps:
1) Update a Aries to 20150820012109
2) Open contacts
3) Select a pre-existing contact
4) Edit the contact and change an existing portion of a contact
5) Confirm the changes
6) Observe status bar

Actual:
the status bar turns white after editing a contact

Expected:
It is expected that the status bar remains the same color

Environmental Variables:
Device: Aries 2.5 
Build ID: 20150820012109
Gaia: 89e0096a3de0378e3eda77e6a2a0bb5ca03eb8bb
Gecko: 29b2df16e961
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Repro frequency: 10/10
See attached: video clip(http://youtu.be/4Z8jnR8ypyA), logcat
(Reporter)

Comment 1

2 years ago
This issue DOES occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
Build ID: 20150820030207
Gaia: 89e0096a3de0378e3eda77e6a2a0bb5ca03eb8bb
Gecko: 29b2df16e961
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Result:
the status bar turns white after editing a contact
-----------------------
This issue DOES NOT occur on Flame 2.2.

Device: Flame 2.2
BuildID: 20150820032506
Gaia: 335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gecko: ebaa55c4247b
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
The status bar does not change color.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(jmercado)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
(Reporter)

Updated

2 years ago
[Blocking Requested - why for this release]:

[Blocking Requested - why for this release]:

Regression. This seems like it might be the same window as bug 1196893.  Lets check the regression window from that when its ready to see if its the same.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
This is indeed the same regression window as Bug 1196893

This issue appears to be caused by:
Bug 1183727 - [Contacts][NGA] Create #update view and connect it to #open within Contacts App

B2G-Inbound Regression Window:

Last Working 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150819054940
Gaia: fa32b801f6d854e846ea8294dc37840450d36c1e
Gecko: 8643f1d9971c76c98bc32a07ae6d3760f3f3a4bb
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150819061537
Gaia: b57de4c493b611dc70c27c7d78445fcb04b1491c
Gecko: 7feeb30abb6856d4176fd0e5eb7b45da18931c49
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Last Working gaia / First Broken gecko - Issue does NOT reproduce
Gaia: fa32b801f6d854e846ea8294dc37840450d36c1e
Gecko: 7feeb30abb6856d4176fd0e5eb7b45da18931c4

First Broken gaia / Last Working gecko - Issue DOES reproduce
Gaia: b57de4c493b611dc70c27c7d78445fcb04b1491c
Gecko: 8643f1d9971c76c98bc32a07ae6d3760f3f3a4bb

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/fa32b801f6d854e846ea8294dc37840450d36c1e...b57de4c493b611dc70c27c7d78445fcb04b1491c
Blocks: 1183727
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
QA Contact: mshuman
Closing this as a duplicate of bug 1196893.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Resolution: --- → DUPLICATE
Duplicate of bug: 1196893
blocking-b2g: 2.5? → ---
You need to log in before you can comment on or make changes to this bug.