Closed Bug 1197176 Opened 4 years ago Closed 4 years ago

Coming back to fennec from the task switcher sometimes doesn't repaint the content area

Categories

(Firefox for Android :: Toolbar, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 43
Tracking Status
firefox41 + verified
firefox42 --- verified
firefox43 --- verified

People

(Reporter: kats, Assigned: kats)

References

Details

Attachments

(1 file)

This seems to be happening pretty frequently on Fennec Nightly, possibly a regression from bug 1180295.

Start Fennec, load a page. Enter the android task switcher, and then re-enter Fennec. The content area is black, but as soon as you touch the screen it repaints correctly.

It looks like we're not requesting a composite when we come back to the foreground. Might be related to bug 1193753 although I can't reproduce that one and I can reproduce this one pretty consistently.
This seems to be very timing-specific. If I wait on the task switcher for a couple of seconds before re-entering Fennec I don't see the problem and everything looks good. If I re-enter Fenenc as soon as possible I see the chrome and content areas flash black and then sometimes the content area gets stuck in black.

Adding some logging seems to indicate that pausing the compositor (which happens synchronously from the java UI thread) is taking a while and if I restore Fennec before it's done I get the flashing/glitching. If I wait until the compositor pause is complete there's no issue.
Attached patch PatchSplinter Review
This seems to do the job.
Attachment #8651016 - Flags: review?(snorp)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #1)
> This seems to be very timing-specific.

For the record this timing-specific-ness seemed to amplified on my local debug build. On the Nightly build I don't think I could resume fennec fast enough to hit this. However on Nightly I noticed that on some pages the issue would reproduce consistently with a scroll offset of 0 but as soon as the page was scrolled even a little bit it wouldn't reproduce. No idea what's going on but the patch fixes it on my local debug build so I'm hoping it'll fix it on Nightly also.
Comment on attachment 8651016 [details] [diff] [review]
Patch

Review of attachment 8651016 [details] [diff] [review]:
-----------------------------------------------------------------

Very weird....a SurfaceView shouldn't really be doing anything itself as far as drawing goes. It just handles positioning and sizing for a Surface which the surfaceflinger paints.
Attachment #8651016 - Flags: review?(snorp) → review+
https://hg.mozilla.org/mozilla-central/rev/07e73fa84838
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Comment on attachment 8651016 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: according to the discussion on bug 1193753, there was probably a pre-existing issue in the code (since forever) that was exposed by bug 1143575.
[User impact if declined]: according to the discussion on bug 1193753, uplifting this may fix a problem with a black screen showing up when closing the settings in fenenc
[Describe test coverage new/current, TreeHerder]: not much but it's a small patch that can't really hurt
[Risks and why]: low risk. worst case we do an extra composite when it's not needed
[String/UUID change made/needed]: none
Attachment #8651016 - Flags: approval-mozilla-aurora?
Comment on attachment 8651016 [details] [diff] [review]
Patch

OK, let's try it. We have time to fix potential fall out. Thanks
Attachment #8651016 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1193753
Kartikaya, bug 1154732 was resolved dup of this issue. Given that this bug also impacts FF41, could you please request uplift to Beta? The patch looks fairly safe and simple.
Flags: needinfo?(bugmail.mozilla)
Moving the FF41 tracking flag from bug 1154732 to here.
I'm not at all convinced that bug 1154732 is a dup of this, and I requested verification on that bug. However this patch is trivial and we can request an uplift to beta regardless.
Flags: needinfo?(bugmail.mozilla)
Comment on attachment 8651016 [details] [diff] [review]
Patch

Approval Request Comment
(see comment 7 and comment 12)
Attachment #8651016 - Flags: approval-mozilla-beta?
Comment on attachment 8651016 [details] [diff] [review]
Patch

Patch has been in Nightly for a while, seems safe to uplift to Beta41 as it's a one-liner.
Attachment #8651016 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified as fixed in builds:
43.0a1 2015-09-03;
42.0a2 2015-09-03;
Device: Asus Transformer Pad (Android 4.2.1).
Verified as fixed in build 41 Beta 8;
Device: Asus Transformer Pad (Android 4.2.1).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.