Closed Bug 119765 Opened 18 years ago Closed 15 years ago

Modern theme description talks about Communicator

Categories

(SeaMonkey :: Themes, defect, trivial)

defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla, Unassigned)

References

Details

(Keywords: polish)

Attachments

(1 file, 1 obsolete file)

Go into Edit -> Prefs -> Apperance -> Themes and mark Modern

The text talks about "Communicator". But there's nothing called Communicator...!
The text should be updated.

build 20020111
OS: Windows 2000 → All
Summary: Themes talks about Communicator → Themes dialog talks about Communicator
Target Milestone: --- → Future
*** Bug 126959 has been marked as a duplicate of this bug. ***
Hardware: PC → All
Easy enough to fix...
Assignee: hewitt → gregvalure
Severity: normal → trivial
Keywords: polish
Summary: Themes dialog talks about Communicator → Modern theme description talks about Communicator
Target Milestone: Future → mozilla1.1alpha
-> me
Status: NEW → ASSIGNED
Attached patch Patch (obsolete) — Splinter Review
On second thought, maybe it would be better if we didn't mention any specific
product at all.  This way we won't need separate versions for Netscape and
Mozilla.
Attachment #94540 - Attachment is obsolete: true
Back to default owner.  Sorry.

I don't know why I can't get a reviewer response on this.  Before they were on
vacation, but now I don't know what's up.  If someone else wants to try to get
this reviewed and checked in, please do.
Assignee: gregvalure → shliang
Blocks: 14532
Status: ASSIGNED → NEW
Keywords: polishpatch
Target Milestone: mozilla1.1alpha → ---
This bug is invalid.

> But there's nothing called Communicator...!

There is. The Navigator/Mailnews/Composer appsuite is technically called
Communicator, see source xpfe/communicator/.
Technically.  But there's nothing exposed to the user referencing Communicator;
nothing in the UI, nothing in the help docs.  Even the Netscape-branded version
is now just Netscape and not Communicator.  We should not expose something that
exists as a source-level convention only to the user.
Comment on attachment 94541 [details] [diff] [review]
Patch (neutral language)

Requesting review from shliang@netscape.com for Gregs patch - see comment #6.
I pondered creating a patch with the app name in it, but I think it is better
this way.
Attachment #94541 - Flags: review?(shliang)
Comment on attachment 94541 [details] [diff] [review]
Patch (neutral language)

I don't think we shoud change this. As mentioned in comment #5, Communicator
does refer to something.
Attachment #94541 - Flags: review?(shliang) → review-
shliang, so this is WONTFIX?

I rather think this should be fixed because "Communicator" has no real meaning
in the Mozilla world. But I don't mind if it isn't.
The main thing is this bug gets resolved one or the other way.
marking invalid
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → INVALID
come on...

Just try to think as a user sometimes! Refering to some technical stuff is just
plain stupid. This is nothing called Communicator from a users point of view!
When downloading, installing and using Mozilla it's always called Navigator!
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Communicator may be used in Mozilla code ("Mozilla Communicator", e.g.), but if
it is in fact not being used, why start now?

/be
but... remember that, for an M$ assimilated user, "Mozilla" isn't more than a
name similar do Godzilla. It isn't suggestive to internet. Not as "Internet
Explorer". Restoring the "Communicator" world (I know that in firebird this
isn't possible, but perhaps when there appear releases of Mozilla containing
Fbird and tbird, and standalone composer), would be good as it sound to
communicate, at least...
Comment on attachment 94541 [details] [diff] [review]
Patch (neutral language)

"Communicator" should never appear on Mozilla UI. I don't see any good reason
why this bug should not be fixed.
Attachment #94541 - Flags: review- → review?(neil.parkwaycc.co.uk)
Assignee: shliang → themes
Status: REOPENED → NEW
Attachment #94541 - Flags: review?(neil.parkwaycc.co.uk) → review+
Keywords: polish
Neil, I don't have CVS account. can you check this in?
Comment on attachment 94541 [details] [diff] [review]
Patch (neutral language)

be: can I take your comment 14 in this bug as an sr+? ;-) Thanks!

I can check this in then.
Attachment #94541 - Flags: superreview?(brendan)
Comment on attachment 94541 [details] [diff] [review]
Patch (neutral language)

Sure.  If neil wants to r+sr these sorts of changes, that's ok with me.

/be
Attachment #94541 - Flags: superreview?(brendan) → superreview+
Fix checked in.
Status: NEW → RESOLVED
Closed: 17 years ago15 years ago
Resolution: --- → FIXED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.