Open Bug 1197782 Opened 5 years ago Updated 4 years ago

draft triggers a manual run of filters

Categories

(Thunderbird :: Filters, defect)

31 Branch
defect
Not set
normal

Tracking

(Not tracked)

UNCONFIRMED

People

(Reporter: mozilla, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150819100805

Steps to reproduce:

Create a filter "googlemail" that sorts all mails that include "googlemail" in from into a certain folder called "googlemail"

(This is just an example, but replace "googlemail" with any other part of your own email, for example your real surname)

select in your filter both "manually run" and "getting new mail" 


Actual results:

when composing a new mail and pressing CTRL+S to save as draft the draft is stored but immediately moved into the "googlemail" folder


Expected results:

The mail should stay in the "Drafts" folder. "manually run" should not be triggered inside the Drafts folder
I cannot reproduce this.

What version were you using when this was reported, and do you still see the issue when using a current version?
Flags: needinfo?(mozilla)
This seems quite improbable, and the reporter has not responded.
So => incomplete
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(mozilla)
Resolution: --- → INCOMPLETE
I think 38.2.0. with IMAP.

Did you try it exactly as described?

use manually run also. Once you press CTRL+S to save the email in the (online IMAP) Drafts folder, if it matches a filter criteria it gets automatically sorted away.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(In reply to Ruben from comment #3)
> I think 38.2.0. with IMAP.
> 
> Did you try it exactly as described?

Is there a step there that you consider unusual?  It reads like a standard filter setup.

What happens if you uncheck the box for "Manual Run"?
See Also: → 681474
You need to log in before you can comment on or make changes to this bug.