If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Media playback fails with Windows N and KN

RESOLVED DUPLICATE of bug 1210231

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1210231
2 years ago
2 years ago

People

(Reporter: Jesús Fernando, Unassigned)

Tracking

Trunk
All
Windows
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8651879 [details]
BUG1.PNG

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150824004008
Firefox for Android

Steps to reproduce:

in this example Youtube
1.- Open Firefox Developer Edition Version 42.0a2 (2015-08-24)
2.- Open Youtube on browser
3.- Put any video to play




Actual results:

On UI it says An Error Ocurred but in console says Media resource mediasource:https://www.youtube.com/6a9abbee-fd4e-40c6-9231-1d683f4619c7 could not be decoded. on every video


Expected results:

the video it must be loaded
(Reporter)

Updated

2 years ago
Severity: normal → major
Component: Untriaged → Web Apps
OS: Unspecified → Windows 7
Priority: -- → P5
Hardware: Unspecified → x86

Updated

2 years ago
QA Whiteboard: [bugday-20150824]
Component: Web Apps → Audio/Video
Product: Firefox → Core

Comment 1

2 years ago
Are you running FF on Android?
Because with FF DE on desktop (Win 7), I have no issue to play any videos on YT.
Flags: needinfo?(jefer_590)
We can't help unless you specify the exact phone make/model.
If it is a desktop issue then it is probably because you're using Windows N or KN.

Comment 4

2 years ago
Running into the exactly the same problem under Windows 10 Pro N 64bits (What's wrong about Windows N versions?)
Details frm about:support just in case it helps


Firefox
42.0a2
20150903004012
aurora
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Safe mode: false



Extensions
-----------

None

Gráphics
--------

hardware H264: false
GPU 1: igdumd64 igd10umd64 igdumdx32 igd10umd32
GPU #2): nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
Intel(R) HD Graphics
NVIDIA GeForce GT 420M
Direct2D: true
DirectWrite: true (10.0.10240.16430)
Encuadre/zoom asíncrono: ninguno
WebGL: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_4_0 ps_4_0)
GPU: 1/1 Direct3D 11 (OMTC)
driver version : 8.15.10.2900
dirver version(GPU #2): 10.18.13.5582
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important modified Preferences
------------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 4
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20150903004012
browser.startup.homepage_override.buildID: 20150903004012
browser.startup.homepage_override.mstone: 42.0a2
browser.tabs.warnOnClose: false
dom.apps.reset-permissions: true
dom.mozApps.used: true
extensions.lastAppVersion: 42.0a2
gfx.direct3d.last_used_feature_level_idx: 1
gfx.driver-init.appVersion: 42.0a2
gfx.driver-init.deviceID: 0x0046
gfx.driver-init.driverVersion: 8.15.10.2900
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
media.gmp-eme-adobe.lastUpdate: 1441316832
media.gmp-eme-adobe.version: 12
media.gmp-gmpopenh264.lastUpdate: 1441316833
media.gmp-gmpopenh264.version: 1.4
media.gmp-manager.buildID: 20150903004012
media.gmp-manager.lastCheck: 1441316828
media.hardware-video-decoding.failed: true
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.history.expiration.transient_current_max_pages: 100357
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.sanitize.migrateFx3Prefs: true

Comment 5

2 years ago
Are they these versions without WMP? Maybe the H264 Video Decoder is missing from Microsoft Media Foundation used by Firefox to decode H264.

Updated

2 years ago
Component: Audio/Video → Audio/Video: Playback

Comment 6

2 years ago
You are right, installing https://www.microsoft.com/en-US/download/details.aspx?id=48231
solved the problem.

Comment 7

2 years ago
Jesús, if you don't have the Media Pack installed on your machine, could you install it and test again, please.

Win 10: https://www.microsoft.com/en-US/download/details.aspx?id=48231
Win 8.1: https://www.microsoft.com/en-US/download/details.aspx?id=40744
Win 8: https://www.microsoft.com/en-US/download/details.aspx?id=30685
Win 7: https://www.microsoft.com/en-US/download/details.aspx?id=16546

Updated

2 years ago
Summary: Media Not encoded (Any Media website like youtube or souncloud) → Media Not encoded (Any Media website like youtube or souncloud) with Windows N and KN
Summary: Media Not encoded (Any Media website like youtube or souncloud) with Windows N and KN → Media playback fails with Windows N and KN

Updated

2 years ago
Duplicate of this bug: 1234930

Updated

2 years ago
Blocks: 799318
Severity: major → normal
Depends on: 1178098
OS: Windows 7 → Windows
Priority: P5 → --
Hardware: x86 → All
Bug 1210231 should fix this.
Depends on: 1210231
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1210231
No longer blocks: 799318
No longer depends on: 1178098, 1210231
Flags: needinfo?(jefer_590)
You need to log in before you can comment on or make changes to this bug.